×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

INDI Server using Linux Subsystems for Windows

2 years 2 months ago
knro
Administrator
Administrator
Posts: 8087
Karma: 51
Topic Author
INDI Server using Linux Subsystems for Windows #25251
This is WAAAAY early stages, but a quick test with the simulators yesterday went just fine.

Have to check today if COM/Serial stuff work. I know that libusb does not work there so this renders all camera as non-working by default. But still, something better than nothing I suppose.

What you see here is INDI Server running under Ubuntu under Windows 10 under VirtualBox under Ubuntu :blink: :blink:


Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Attachments:

Please Log in or Create an account to join the conversation.

1 year 5 months ago
kengs
Expert Boarder
Expert Boarder
Posts: 153
Karma: 3
More
INDI Server using Linux Subsystems for Windows #33755
I finally got around to trying this out. I started with the Avalon mount which for me is on COM7.
I first did an apt-get install indi-full, then started indiserver.
To get access to the COM port I had to chmod 666 /dev/ttyS7
Then fired up Ekos (and PHD2) and connected to the mount, slewed, parked etc...
I also installed astrometry.net and ansvr and got it 90% working from the Ekos alignment module. That is it solved an image behind the scenes but the ansvr Jnow converter failed (it was compiled for Cygwin). I've reached out to Andy to see if something can be done so fingers crossed.
So what we need now is either libusb support or some way to bridge across to Windows

Ubuntu 16.04 AMD64 VM, RPi3 Ubuntu Mate 16.04, Windows 10 AMD64, Ubuntu 16.04 AAEON UP Core
Avalon M-Uno, EQ6 Pro, Atik420, ASI1600MM-C, ASI120MM-S, DBK21AU04, ZWO EFW, Optec TCFSi
Vixen R150S, GSO RC8, ST80

Please Log in or Create an account to join the conversation.

1 year 5 months ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1541
Karma: 7
More
INDI Server using Linux Subsystems for Windows #33757
When you chmod a tty device, it will be reset when you connect the mount again. A better way is to make sure that your Linux user is in the appropriate group. This very likely is the group dialout but I am not 100% sure. Please do an

ls -l /dev/ttyS7

to see the group. See here

www.cyberciti.biz/faq/howto-linux-add-user-to-group/

on how to add the user to a group on Linux.


HTH, Wouter

ASI6200 and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

Time to create page: 0.215 seconds