×
INDI Library v1.8.4 Released

Minor bugfix release with some highlights:

AstroPi3 Scripts revised

4 months 4 weeks ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45382
Rob,
I've just tried to use the latest AstroPI3 Raspbian Buster script on a Raspberry Pi 4 and it all runs through fine, but there are no third party cameras showing in the drop down menu for either the main ccd or guide ccd in the Ekos Profile Editor, also the cameras are also missing from PHD2 drop down menus. I have an older version of the script and it is working fine.
The generic & simulator cameras are present & are able to be selected, the driver files for the third party cameras appear in the folder /home/pi/AstroRoot/indi-3rdparty .
The focusers, mounts & filter wheels are all present in their respective drop down menus, I've tried a few times with different SD cards SanDisk Extreme 32 GB and using both Etcher and Win32 Disk Imager, same result every time.

Regards Alan

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2125
Karma: 21
More
Topic Author
AstroPi3 Scripts revised #45409
So if you do these two commands in the terminal on the machine that is giving you trouble:

ls /usr/bin/indi*
ls /usr/share/indi

Do you see the drivers and the xml files? Are they all there?

Thanks,

Rob

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
Avocette
Expert Boarder
Expert Boarder
Posts: 92
More
AstroPi3 Scripts revised #45411
Hi Rob, I thought I'd make up a fresh SD Card installation and so this wet evening I've also run the new version of the your script under Raspbian. I also have found that the cameras available in the drop down list when setting up your equipment profile are very restricted in number with the ones I am interested in (Canon DSLR and ZWO) missing. Also under the Aux drop down list, GPSD is no longer present although GPSUSB and GPS Simulator remain. I guess this is due to the build of KStars which was cloned tonight?
Ed

Currently running KStars/Ekos/Indi on a Raspberry Pi 4B 2GByte under Raspbian thanks to AstroPi3 Script
Sky-Watcher ED80 Pro with 0.85x FR/Corrector with Canon DSLR on AZ-EQ5 GT mount
Other Sky-Watcher scopes - SkyMax 150 Pro Maksutov Cassegrain and Explorer 150p Newtonian

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2125
Karma: 21
More
Topic Author
AstroPi3 Scripts revised #45412
did you try those two commands that I mentioned. I would like to know if the drivers are all installed and all the xml files.

I am assuming the 3rd party build went ok including both libraries and drivers ? were there any failures along the way?

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45413
Rob,
Many Thanks for the reply I've just tried ls /usr/bin/indi* all the drivers for the Mounts, Focusers, Filter Wheels and auxiliaries show up there, but there are no Camera drivers visible.

ls /usr/share/indi there is only following xml files showing, drivers.xml indi_tcfs_sk.xml

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45414
Rob,
The build seemed to go OK it didn't hang or crash in any way it appeared to run just like the previous successful setups I've done from the earlier versions of the script, I have also tried running the script on the light version of Raspbian Buster with the same result.

I have also re run on a Pi 4 one of the previous scripts from a backup I have and it has installed fine, all the cameras are fully installed

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2125
Karma: 21
More
Topic Author
AstroPi3 Scripts revised #45415
That sounds like either it didn't install the 3rd Party drivers, or they installed someplace different.

Can you try
ls /usr/local/bin/indi*
ls /usr/local/share/indi

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2125
Karma: 21
More
Topic Author
AstroPi3 Scripts revised #45416
Or better yet, instead of looking for them, look at the contents of the file

/home/pi/AstroRoot/indi-build/3rdparty-Drivers/install_manifest.txt

See if they installed, and if so, where?

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2125
Karma: 21
More
Topic Author
AstroPi3 Scripts revised #45417
Or alternately, try these commands:

cd ~/AstroRoot/indi-build/3rdparty-Drivers
sudo make install

And see if they install or if there is an issue.

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45418
Rob,
I've tried that for you here is the result

pi@raspberrypi:~/AstroRoot/indi-build/3rdparty-Drivers $ sudo make install
make: *** No rule to make target 'install'. Stop.

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
rlancaste
Platinum Boarder
Platinum Boarder
Posts: 2125
Karma: 21
More
Topic Author
AstroPi3 Scripts revised #45420
And if you do
ls ~/AstroRoot/indi-build/3rdparty-Drivers

Is that directory empty?

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
ar2star2
Junior Boarder
Junior Boarder
Posts: 37
More
AstroPi3 Scripts revised #45421
Rob,
I've just looked in the indi-build / 3rdparty-drivers and there's no manifest.txt screen dump attached

Raspberry Pi3B,ASI120MC Usb2, QHY5Lii Mono, Atik CCD, Canon 600D, NEQ6, EQMod, EQ5, AstroEQ, EQMod Equinox ED80
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 1.004 seconds