INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

Finally solved: GPS doesn't work on RP4, only on RP3 or PC

  • Posts: 8
  • Thank you received: 6
For weeks I couldn't figure out, why my GPS USB Dongle (10€, U-Blox7) didn't work with Stellarmate on RP4. If anybody has similar problems, I hope this post helps them:

On the PC or with RP3, the GPS Dongle will get the current positon in a matter of seconds. On the RP4, I could leave it running for hours without a fix. GPSD lets me see that the dongle is picking up the signal of many satellites, but for some reasons there was never a fix possible.

Today I realized, that the USB3 connection of the RP4 interferes with the GPS Signal. It depends on the connected device: A CMOS camera or USB-Stick connected by USB3 doesn't cause much interference. But as soon as I connect the PegasusAstro Pocket Powerbox Advance via USB3, the GPS can't get any usable signal anymore. Even if the GPS is pluged into a completeley different device 50cm away, the interference is still too strong.

I now connect the Powerbox only via USB2, that solved the problem and I can use the GPS dongle without issues. Of course this has the downside that I can't use the USB3 speeds at the Hub on the Powerbox anymore. Luckily the only two devices that I need USB3 speeds for (Camera and USB-Storage) can fit on the RP4 directly and don't cause too much interference.
9 months 2 weeks ago #57227

Please Log in or Create an account to join the conversation.

  • Posts: 337
  • Thank you received: 104
This is a variant of the USB3 issue documented here:
Although you've found a solution that works, there may be other solutions that could work for you (or others). See the post for details.
Cheers, Doug
RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.
9 months 2 weeks ago #57229

Please Log in or Create an account to join the conversation.

Time to create page: 0.299 seconds