×
INDI Library v1.8.3 Released (02 Jan 2020)

Minor monthly bugfix release with a new RainbowAstro mount driver and improved pier side simulation.

Using Astap solver

1 month 2 weeks ago
CapnRon
Senior Boarder
Senior Boarder
Posts: 77
More
Topic Author
Using Astap solver #47852
I am running on a Rpi 4. I have Astroberry working and connected to my equipment. thank you for this development. I downloaded Astap solver (/opt/Astrometry) and a bunch of index files. I have not set everything up , so I cannot try a solve from inside Kstars, but I can run the ASTAP program free standing. However, I do have a fits star image and I am trying to use the local Astrometry.net. I do not know what to put in that field for the path to astrometry.net. I have no such file, I have an executable astap and I have index files, but it does not accept either of those locations.

Can someone help me configure ASTAP for stand alone use?

thanks,
Ron

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
Kaczorek
Moderator
Moderator
Posts: 799
Karma: 6
More
Using Astap solver #47860
You have to install ASTAP or astrometry. The former must be installed after downloading .deb file from ASTAP site, the latter can be installed with: sudo apt install astrometry.net
Remember to download index files for astrometry. You can do it in ekos align tab options.

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
The following user(s) said Thank You pug916

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
CapnRon
Senior Boarder
Senior Boarder
Posts: 77
More
Topic Author
Using Astap solver #47865
thank you. I am in the process of downloading the recommended index files now.

Please Log in or Create an account to join the conversation.

1 month 2 weeks ago
CapnRon
Senior Boarder
Senior Boarder
Posts: 77
More
Topic Author
Using Astap solver #47904
This is just for information, I don't really have a question yet, as I am not familiar enough with plate solving. I have local versions of ASTAP and Astrometry.net installed and working (I can run them outside of EKOS from a command line). I was able to take a few images around Polaris (not quite on target) a few nights ago. What I find is that I can solve those images using both "online" and "offline" Astrometry.net with its index files, but they don't solve with ASTAP. I am feeding both programs the same configuration information in terms of estimated FOV, downsampling, estimated RA and DEC values, etc. The documentation for command line input for Astrometry.net is much clearer than what I have for ASTAP. I downloaded TopCat on my PC ( the solvers are running on an Rpi 4) so I can read the list files. There is nothing in them that gives me any clue as to why Astrometry works, but ASTAP does not (works in the sense of solves the images). I have tried a couple of images with the same results. The image scale is around 1.2 arcsec/pix.

If anyone has any thoughts on how to understand and use the settings available in ASTAP I would appreciate their comments.

thanks,
Ron

Please Log in or Create an account to join the conversation.

1 month 1 week ago
han.k
Gold Boarder
Gold Boarder
Posts: 206
Karma: 6
More
Using Astap solver #48076
Ron,

Both should work with the difference that Astrometry.net will solve even with the wrong FOV. But Astrometry.net is slower. With ASTAP it will solve within 5 or 10 seconds on the Raspberry Pi.

Can you provide a link to one of your images, so I can have a look to the header? Tell me also which binning setting you set in Ekos for solving.

Han

Please Log in or Create an account to join the conversation.

1 month 1 week ago
fewayne
Senior Boarder
Senior Boarder
Posts: 66
More
Using Astap solver #48083
Oddly enough, on my RPi 4 I get slightly faster solving with astrometry.net offline than I do with ASTAP. All default settings, 40MB FITS file from my 183MM, just clicking "Load and Solve" from Ekos. I get around 15 seconds on average with ASTAP, 11 with astro.net.

For anyone reading this, the really stupid-simple way to get ASTAP installed is to point your PC's browser at stellarmate.local, go to the "Software" page on the resulting dashboard, and have it install ASTAP. Installs g17 for you too. Nice work there!

Of course your Pi has to be able to see the Internet to accomplish this.
The following user(s) said Thank You pug916

Please Log in or Create an account to join the conversation.

1 month 1 week ago
the.cakemaker
Gold Boarder
Gold Boarder
Posts: 303
More
Using Astap solver #48105
Getting mad here again.

Installed astap because i wanted to try.
Found astap in /opt/astap/astap

I either get the message, that the file can not be found or that the permission is denied...

As a "not-so-much" Linux user, this again and again "not allowed to blablabla" thing is REALLY annoying...

So where the hell can i move the astap files to, so that kstars is allowed to use it?

Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Canon EOS 5DMarkIIIa | ASI120mm guiding cam | KSTARS 3.3.9 on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.3.9 on Remote-IMac with Catalina 10.15.2

Please Log in or Create an account to join the conversation.

1 month 1 week ago 1 month 1 week ago by han.k.
han.k
Gold Boarder
Gold Boarder
Posts: 206
Karma: 6
More
Using Astap solver #48109
The correct location of the astap executable is at /opt/astap . That location will be created using the provided Debian package for installation. Both the executable and .290 files are in this location.

Please Log in or Create an account to join the conversation.

1 month 1 week ago
the.cakemaker
Gold Boarder
Gold Boarder
Posts: 303
More
Using Astap solver #48120
Thats where it is...

Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Canon EOS 5DMarkIIIa | ASI120mm guiding cam | KSTARS 3.3.9 on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.3.9 on Remote-IMac with Catalina 10.15.2
Attachments:

Please Log in or Create an account to join the conversation.

1 month 1 week ago
han.k
Gold Boarder
Gold Boarder
Posts: 206
Karma: 6
More
Using Astap solver #48123
Okay, next thing to check if you can execute astap from the menu education or just type the command /opt/astap/astap. Then try to load and solve an image manually in astap.

Han

Please Log in or Create an account to join the conversation.

1 month 1 week ago
the.cakemaker
Gold Boarder
Gold Boarder
Posts: 303
More
Using Astap solver #48125
Found the fault.

I installed the wrong package it seems. Now i installed the_amd64 version and it seems to work.

But how would i know which one is the right one?

nevermind...

Thanx, Niki

Skywatcher EQ6-R | Lacerta 10" Carbon-Newton | Lacerta MFoc Motorfocus | Canon EOS 5DMarkIIIa | ASI120mm guiding cam | KSTARS 3.3.9 on my outdoor-Laptop with KDE-Neon/Plasma | KSTARS 3.3.9 on Remote-IMac with Catalina 10.15.2

Please Log in or Create an account to join the conversation.

1 month 1 week ago
han.k
Gold Boarder
Gold Boarder
Posts: 206
Karma: 6
More
Using Astap solver #48126
Good it works for you. The Debian package installer should warn for the wrong architecture.

Please Log in or Create an account to join the conversation.

Moderators: Kaczorek
Time to create page: 0.743 seconds