×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

DSLR INDI crash (EKOS Debugger)

  • Posts: 113
  • Thank you received: 5
Hi,

I have been having issues with crashes for a while, for the most part, nothing happens. During my time I found the common denominator as being related to the camera module (Canon DSLR) which I noticed is associated with G-Photo.
The crash affect every tab that uses the camera module, (Focuser, Capture, Schedular and Align) and I visually saw it crash straight when taking an image.

Anyway, I installed EKOS Debugger and got the report.

 
Malcolm
Telskop Service TS80 480mm APO FL53 Glass
Canon 450D DSLR
ASI120MM Guide camera.
HEQ5 Pro
TIC Focuser NG
Raspberry Pi 4 8GB with Astroberry
6 months 6 days ago #80373
Attachments:

Please Log in or Create an account to join the conversation.

Thank you for the logs. The Canon driver is immediately stopped after connecting, and that led to KStars crashing subsequently. That shouldn't have happened even if the driver crashed, so need to investigate this further. At any rate, need to figure out why. Can you run Ekos Debugger, but this time select the Canon driver to debug instead in the INDI tab? Then start KStars and edit your profile, just change "Local" to "Remote" and save and then click Start. If the driver crashes, we'll get logs for it.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
6 months 6 days ago #80380

Please Log in or Create an account to join the conversation.

  • Posts: 91
  • Thank you received: 7
I've been having a similar problem using a Sony camera running on Mac. The most common manifestation is when a sequence starts and on the first camera collection, that is after the focus and plate solve, the system hangs when the first exposer starts downloading.. I haven't noticed problems in focus or align but it seems like the current version 3.5.7 crashes more ofter than 3.5.6.

Kurt
6 months 5 days ago #80384

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 5
Hi Jasem,

I reported this a little time ago and it didn't go any further. A common log I found is attached in this post - www.indilib.org/forum/ekos/11176-kstar-e...ding-of-drivers.html

The log is where the driver load fails, although there are instances most of the time where it fails well after loading the Canon DSLR driver. Logs simply stop reporting. I apologise, I do not have recent logs. This was from the remote setup but the same occurs for both remote and local operations. I will be setting up detailed logs concentrating only on the Canon Driver only leaving the rest out.

Cheers
Malcolm
Telskop Service TS80 480mm APO FL53 Glass
Canon 450D DSLR
ASI120MM Guide camera.
HEQ5 Pro
TIC Focuser NG
Raspberry Pi 4 8GB with Astroberry
6 months 5 days ago #80387

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
I can add some more information to this topic.  I have been working on finding a solution to this problem too for the last several days.  I am using a Canon 450D DSLR (which used to connect to KStars just fine), camera is read and and can be controlled by gphoto2, using a laptop running Ubuntu 20.04 LTS.

Two clues:
1. When installing INDI using the method below, the DSLR connects fine:sudo apt-add-repository ppa:mutlaqja/ppa
sudo apt-get update
sudo apt-get install indi-full gsc
sudo apt-get install indi-full kstars-bleeding

2. Then after I install the development environment using the method below, the DSLR will no longer connect: ( I need the development environment because I have to load some custom drivers that I developed. )
sudo apt-get install qtcreator
sudo apt-get install libnova-dev libcfitsio-dev libusb-1.0-0-dev zlib1g-dev libgsl0-dev build-essential cmake git libjpeg-dev libcurl4-gnutls-dev libfftw3-dev librtlsdr-dev
mkdir ~/Projects
cd ~/Projects
git clone github.com/indilib/indi.git
mkdir -p ~/Projects/build/indi
cd ~/Projects/build/indi
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Debug ~/Projects/indi
sudo make install

************************************
Here is what it looks like when I try to start the driver using the command line =>

2022-03-03T02:54:29: Driver indi_canon_ccd: restart #10
2022-03-03T02:54:29: Driver indi_canon_ccd: pid=7543 rfd=0 wfd=6 efd=7
2022-03-03T02:54:29: Driver indi_canon_ccd: Number of cameras detected: 1.
2022-03-03T02:54:29: Driver indi_canon_ccd: Detected camera model Canon EOS 450D (PTP mode) on port usb:001,007
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Telescope Simulator.EQUATORIAL_EOD_COORD
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Telescope Simulator.EQUATORIAL_COORD
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Telescope Simulator.TELESCOPE_INFO
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Telescope Simulator.GEOGRAPHIC_COORD
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Telescope Simulator.TELESCOPE_PIER_SIDE
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Rotator Simulator.ABS_ROTATOR_ANGLE
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Focuser Simulator.ABS_FOCUS_POSITION
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Focuser Simulator.FOCUS_TEMPERATURE
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on CCD Simulator.FILTER_SLOT
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on CCD Simulator.FILTER_NAME
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on SQM.SKY_QUALITY
Child process 7543 died
2022-03-03T02:54:29: Driver indi_canon_ccd: stderr EOF
<delProperty device="Canon DSLR EOS 450D (PTP mode)"/>
2022-03-03T02:54:29: Driver indi_canon_ccd: Terminated after #10 restarts.
2022-03-03T02:54:29: good bye

Any help figuring this out would be appreciated. This DSLR worked ok with an older configuration using the same setup method (about 2 years ago).

Thanks,
Doug
5 months 1 week ago #81040

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
I can add some more information to this topic.  I have been working on finding a solution to this problem too for the last several days.  I am using a Canon 450D DSLR (which used to connect to KStars just fine), camera is read and and can be controlled by gphoto2, using a laptop running Ubuntu 20.04 LTS.

Two clues:
1. When installing INDI using the method below, the DSLR connects fine:sudo apt-add-repository ppa:mutlaqja/ppa
sudo apt-get update
sudo apt-get install indi-full gsc
sudo apt-get install indi-full kstars-bleeding

2. Then after I install the development environment using the method below, the DSLR will no longer connect: ( I need the development environment because I have to load some custom drivers that I developed. )
sudo apt-get install qtcreator
sudo apt-get install libnova-dev libcfitsio-dev libusb-1.0-0-dev zlib1g-dev libgsl0-dev build-essential cmake git libjpeg-dev libcurl4-gnutls-dev libfftw3-dev librtlsdr-dev
mkdir ~/Projects
cd ~/Projects
git clone github.com/indilib/indi.git
mkdir -p ~/Projects/build/indi
cd ~/Projects/build/indi
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Debug ~/Projects/indi
sudo make install

************************************
Here is what it looks like when I try to start the driver using the command line =>

2022-03-03T02:54:29: Driver indi_canon_ccd: restart #10
2022-03-03T02:54:29: Driver indi_canon_ccd: pid=7543 rfd=0 wfd=6 efd=7
2022-03-03T02:54:29: Driver indi_canon_ccd: Number of cameras detected: 1.
2022-03-03T02:54:29: Driver indi_canon_ccd: Detected camera model Canon EOS 450D (PTP mode) on port usb:001,007
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Telescope Simulator.EQUATORIAL_EOD_COORD
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Telescope Simulator.EQUATORIAL_COORD
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Telescope Simulator.TELESCOPE_INFO
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Telescope Simulator.GEOGRAPHIC_COORD
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Telescope Simulator.TELESCOPE_PIER_SIDE
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Rotator Simulator.ABS_ROTATOR_ANGLE
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Focuser Simulator.ABS_FOCUS_POSITION
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on Focuser Simulator.FOCUS_TEMPERATURE
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on CCD Simulator.FILTER_SLOT
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on CCD Simulator.FILTER_NAME
2022-03-03T02:54:29: Driver indi_canon_ccd: snooping on SQM.SKY_QUALITY
Child process 7543 died
2022-03-03T02:54:29: Driver indi_canon_ccd: stderr EOF
<delProperty device="Canon DSLR EOS 450D (PTP mode)"/>
2022-03-03T02:54:29: Driver indi_canon_ccd: Terminated after #10 restarts.
2022-03-03T02:54:29: good bye

Any help figuring this out would be appreciated. This DSLR worked ok with an older configuration using the same setup method (about 2 years ago).

Thanks,
Doug
5 months 1 week ago #81041

Please Log in or Create an account to join the conversation.

  • Posts: 113
  • Thank you received: 5
Turns out mine is a different issue, I am using a 450D as well, but my recent crashing seems to be related to FITS Viewer. I will be updated my other post with a little bit more.
Malcolm
Telskop Service TS80 480mm APO FL53 Glass
Canon 450D DSLR
ASI120MM Guide camera.
HEQ5 Pro
TIC Focuser NG
Raspberry Pi 4 8GB with Astroberry
The following user(s) said Thank You: Doug Holland
5 months 1 week ago #81087

Please Log in or Create an account to join the conversation.

  • Posts: 8
  • Thank you received: 0
 

File Attachment:

File Name: log_00-52-42.txt
File Size:18 KB

Attached is a log file that I produced while the described problem was occurring.  I did try selecting Remote instead of Local as requested, but it seemed to be keeping Ekos from starting at all.  The log was created by selecting CCD in the log options and deselecting INDI. 

The driver for the Canon camera driver crashes after I install the development environment and build libindi per the instructions on the web page.  As I said in my original post, the Canon camera driver works fine when I just install INDI / KStars / Ekos on the Ubuntu computer I am using.  The problem occurs only after loading the development environment and building from the indi.git clone.

Any ideas would be appreciated.
Thanks -
Doug

 
5 months 1 week ago #81116
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.680 seconds