×

INDI Library v1.9.7 Released (29 Jul 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Problem updating indi-full

  • Posts: 23
  • Thank you received: 1
I ran into this problem this morning...

======================================
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
indi-full : Depends: indi-astromechfoc but it is not installable
Depends: indi-dreamfocuser but it is not going to be installed
E: Broken packages
=====================================

I assume it's a glitch in the new library release. Any help?
AT8RC Astrograph on CGX mount
ASI-071 C camera or
Pentax K3ii DSLR
60mm Orion guide scope w/QHY5II camera
Feather Touch 2" focuser w/ Focus Lynx auto focus
PPB Power Center, GPS, Temp/Humidity Sensor
7 port powered USB hub to HP Laptop over 30' powered USB cable
KStars / EKOS
3 years 2 months ago #39020

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
I've just run into this same problem :( Hoping there is a quick fix! :)
3 years 2 months ago #39048

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 1
"Hoping there is a quick fix!"

Me too! I've just made my problem worse by purging indi-full. I was hoping that a fresh start would fix things but it didn't and now I have no drivers at all.
AT8RC Astrograph on CGX mount
ASI-071 C camera or
Pentax K3ii DSLR
60mm Orion guide scope w/QHY5II camera
Feather Touch 2" focuser w/ Focus Lynx auto focus
PPB Power Center, GPS, Temp/Humidity Sensor
7 port powered USB hub to HP Laptop over 30' powered USB cable
KStars / EKOS
3 years 2 months ago #39049

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 1
Follow up to my last post. I tried using "aptitude" instead of "apt". Still no joy but I got a more complete error message....
==================================================
The following packages have unmet dependencies:
indi-full : Depends: indi-astromechfoc which is a virtual package and is not provided by any available package

The following actions will resolve these dependencies:

Keep the following packages at their current version:
1) indi-full [Not Installed]
=========================================================

I see that similar problems have occurred in the past. I'm sure it's just a glitch in the new driver set that will be cured in a day or so.
AT8RC Astrograph on CGX mount
ASI-071 C camera or
Pentax K3ii DSLR
60mm Orion guide scope w/QHY5II camera
Feather Touch 2" focuser w/ Focus Lynx auto focus
PPB Power Center, GPS, Temp/Humidity Sensor
7 port powered USB hub to HP Laptop over 30' powered USB cable
KStars / EKOS
3 years 2 months ago #39050

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 1
Problem solved - everything loaded correctly this morning.
AT8RC Astrograph on CGX mount
ASI-071 C camera or
Pentax K3ii DSLR
60mm Orion guide scope w/QHY5II camera
Feather Touch 2" focuser w/ Focus Lynx auto focus
PPB Power Center, GPS, Temp/Humidity Sensor
7 port powered USB hub to HP Laptop over 30' powered USB cable
KStars / EKOS
3 years 2 months ago #39085

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 0
Just tried again with mine and I'm still getting the same errors :(
3 years 2 months ago #39115

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
Same here in Ubuntu on Raspberry Pi3
3 years 2 months ago #39145

Please Log in or Create an account to join the conversation.

Thanks for the report, I restart the build process for this one driver so hopefully in 1-2 hours it should be fine to update.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Simon Dodd
3 years 2 months ago #39148

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
Sorry,
still not working on astroberry-server (Ubuntu16.04) on raspberry Pi 3. In your repo there are no .deb packages for ubuntu 16.04 for indi-astromechfoc and indi-dreamfocuser. After installing the 18.04 debs per hand the upgrade of indi-full worked without problems. Hope you can fix this for others.
Thanks for your great work on indi.
Frank
3 years 2 months ago #39172

Please Log in or Create an account to join the conversation.

Right, I just found the issue that was blocking the build and will rebuild again now.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
3 years 2 months ago #39173

Please Log in or Create an account to join the conversation.

Time to create page: 0.436 seconds