×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

eqmod driver crash on last nightly build

3 months 1 week ago
djibb
Senior Boarder
Senior Boarder
Posts: 64
More
Topic Author
eqmod driver crash on last nightly build #51443
Hi all,

on a odroid, fresh update on nightly build :
odroid@NAFABox:~$ indiserver -vv indi_eqmod_telescope
2020-03-31T15:45:12: startup: indiserver -vv indi_eqmod_telescope
2020-03-31T15:45:12: Driver indi_eqmod_telescope: pid=4359 rfd=3 wfd=6 efd=7
2020-03-31T15:45:12: listening to port 7624 on fd 4
2020-03-31T15:45:12: Driver indi_eqmod_telescope: sending <getProperties version='1.7'/>

2020-03-31T15:45:12: Driver indi_eqmod_telescope: indi_eqmod_telescope: symbol lookup error: indi_eqmod_telescope: undefined symbol: tty_set_skywatcher_udp_format
2020-03-31T15:45:12: Driver indi_eqmod_telescope: stderr EOF

I've tried it on my laptop too (amd64) it crashes too.

Any idea ?

Please Log in or Create an account to join the conversation.

3 months 1 week ago
Zyziuk
Fresh Boarder
Fresh Boarder
Posts: 2
More
eqmod driver crash on last nightly build #51478
Hello all,

I had the same problem a few days ago when developing a new driver for sestosenso2 focuser, which was caused by the LOG_ERROR function - too long argument was passed to the logger. Maybe the same issue ?

Please Log in or Create an account to join the conversation.

3 months 1 week ago
jpaana
Gold Boarder
Gold Boarder
Posts: 256
Karma: 5
More
eqmod driver crash on last nightly build #51494
This is a build issue, there was a renaming of a function in base INDI library (tty_set_skywatcher_udp_format -> tty_set_generic_udp_format) and the nightly eqmod build seems to have been built with the old library version. So it should fix itself in a nightly or two. This is unfortunately a recurring issue when APIs change as there aren't versioned dependencies in place. When compiling yourself it's easy to avoid by always compiling the base INDI library first before 3rd-party drivers.

Remote observatory running Ubuntu 20.04 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub

Please Log in or Create an account to join the conversation.

Time to create page: 0.292 seconds