×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight?

9 months 4 days ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 410
Karma: 3
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #35155
So Alfred WAS right!

The binning introduced a division by 3, resulting in % not equal 0.

Good eye, Alfred!!

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
The following user(s) said Thank You Herrhausen

Please Log in or Create an account to join the conversation.

9 months 4 days ago 9 months 4 days ago by Herrhausen.
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 516
Karma: 3
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #35158
I'm glad to hear I - for once - might have contributed something helpful. As a non-coder I always feel like being somewhat retarded here. Anyway, I hope we successfully hunted down this bug. BTW, I've used Ekos 3 nights in a row and other than some missing pixels I have not experienced any issues. Simply wonderful!

Please Log in or Create an account to join the conversation.

9 months 3 days ago 9 months 3 days ago by knro.
knro
Administrator
Administrator
Posts: 7379
Karma: 51
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #35159
Thanks Alfred and everyone who contributed to this thread!

Please try to test this change in the updated KStars tonight and see if the issue with binning is gone.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

9 months 3 days ago
soffici
Junior Boarder
Junior Boarder
Posts: 32
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #35165

knro wrote: Because if it is ATIK CCD, then the driver was changed recently to the officially supported version from ATIK, and everyone reported the size changes.

Indeed you did!
Thank you! Now my Atik 383 world like a charm (well, an OLD charm, but still..)
Cheers
Antonio

Please Log in or Create an account to join the conversation.

9 months 3 days ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 410
Karma: 3
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #35168
Will test as soon as possible, but the weather forecast here for the next 10 days shows only clouds....

Thanks for fixing this so promptly, Jasem!

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

9 months 3 days ago
Herrhausen
Platinum Boarder
Platinum Boarder
Posts: 516
Karma: 3
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #35171
I don't want to proclaim victory too early but I tested the latest code indoor and the results are perfect. I was focusing in 2x2, shot a few 1x1bin frames from the queue, solved in 2x2 and again shot a few 1x1bin frames. They all were of the correct dimension. I expect the same results in the night sky. Many thanks for sorting this out!
The following user(s) said Thank You knro, El Corazon

Please Log in or Create an account to join the conversation.

8 months 3 weeks ago
fusis
Senior Boarder
Senior Boarder
Posts: 41
More
Topic Author
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #35557
Hi,

I wanted to tell you that this issue was solved. I did test it the night after the driver was fixed. And indeed no more missing rows of pixels in the first frame after a change of binning. But the last few nights I have been really struggeling with the ASI drivers. I get loads of crashed asi drivers messages, mostly when trying binning 4x4, 3x3 and also 2x2. If I refrain from binning and stay on 1x1 all is fine. The images taken when binning 3x3 and 4x4 look very strange, there are slanting bands in the image. Mostly after one image is taken it crashes the asi driver.

I use an ASI294MC.

Yesterday also the ASI385 crashed the driver, this was after guiding fine for some 20 to 30 minutes. This is new, I did not have this before yesterdays update to the nightly builds.

I will post Logs later today, I can not reach them at the moment. But I wanted to let you know. Maybe there's more users affected?

FYI I tested binning on a laptop with sharpcap. Nu issues with binning there, so it's not the camera (I guess).

Marco
EKOS - Stellarmate Nightly Builds | EQ5Pro | ZWO ASI294MC Pro | ZWO ASI385MC | HiTecAstro DC Focus

Please Log in or Create an account to join the conversation.

8 months 3 weeks ago 8 months 3 weeks ago by El Corazon.
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 410
Karma: 3
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #35559
I agree with you that that problem was solved. All downloaded images now have the correct dimensions in my last two tests.

I also agree that there is (probably) a problem with binning 4x4, I saw a similar distorted image, but did not investigate further at this time, since everything was working fine with 3x3 binning.

But the much bigger problem is this:

indilib.org/forum/ekos/4670-solver-fails...scheduler.html#35492

Whatever changes were made have now completely killed the scheduler. Because, if the alignment module can no longer capture an image, it obviously cannot align and if it cannot align you can't use the scheduler, unless you are into collecting images from random sections of the sky.

Here are the logs from 2 nights ago. Although I am not certain what all the lines mean, it is very clear that something is very wrong when half the log consists of warnings that something "failed for trixel 32"

www.dropbox.com/sh/jsu99h7geo6sgss/AACUm...76w67XR5ETf5gUa?dl=0

This concerns the KStars version (nightly) Jasem refers to in his post 35159.

Jo

PS: To reemphasize: The problem with the alignment module not capturing an image occurs ONLY in the scheduler. If the alignment module is used outside the scheduler, it works fine. So only users who have tried using the scheduler will likely have experienced this bug.

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

8 months 2 weeks ago
fusis
Senior Boarder
Senior Boarder
Posts: 41
More
Topic Author
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #35673
I think it is better to start a new topic: ASI294Pro Binning issue 3x3 and 4x4, so I did please look for it.

Marco
EKOS - Stellarmate Nightly Builds | EQ5Pro | ZWO ASI294MC Pro | ZWO ASI385MC | HiTecAstro DC Focus

Please Log in or Create an account to join the conversation.

7 months 4 weeks ago
Kaczorek
Moderator
Moderator
Posts: 652
Karma: 6
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #36951

El Corazon wrote: I am not sure this is a PixInsight problem.
The ATIK website lists the sensor geometry of the Atik 460EX as 2749x2199.


I have been OK with this finding for last couple of weeks.... However my FITS files from Atik 460EX are showing 2750x2200 geometry (+1 in x and y).
Anybody facing this issue again?

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM

Please Log in or Create an account to join the conversation.

7 months 4 weeks ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 410
Karma: 3
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #36953
When you take one of the FITS files and open it in Photoshop or Gimp, how many pixels does it show there when you select Canvas size and image size?
I.e. is the header right or not?

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

7 months 4 weeks ago
Kaczorek
Moderator
Moderator
Posts: 652
Karma: 6
More
Can not calibrate Images captured with EKOS (stellarmate) in Pixinsight? #36955
Both FITS header and actual resolution (checked in PixInsight and Gimp) are 2750x2200.

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM

Please Log in or Create an account to join the conversation.

Time to create page: 0.597 seconds