INDI Library v2.0.4 Released (01 Oct 2023)

Bi-monthly release with minor bug fixes and improvements

AstroPi3 Scripts revised

It's due to recent change in KStars options. I've added a method around that for older systems, please git pull and try again.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Andrew
1 year 5 months ago #83679

Please Log in or Create an account to join the conversation.

  • Posts: 1309
  • Thank you received: 226

Replied by Andrew on topic AstroPi3 Scripts revised

Seems to be working. Thank you :)
Can you elaborate on the 'older systems' point?
Is a system resources issue? I was compiling on a Raspberry Pi 4 with only 4gb of memory.
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
1 year 5 months ago #83689

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
I have tried this script on a Raspberry Pi 4 running Raspbian Bullseye 64-bit. One issue is that it messes up my wifi and lan connections, network manager never starts on its own. This I can easily fix myself.
However, a more devestating problem is that none of the astrophotgraphy related software seems to be built/installed(or whatever the terminology is) correctly. A folder containing several gigabytes of data called Astroroot is created which does contain a set of folders named after the various astrophotography software. But I can not find any way of running them. There are no icons created either on the desktop or in the "start menu". How do I find out what has gone wrong so that I can fix it?
9 months 3 weeks ago #90250

Please Log in or Create an account to join the conversation.

  • Posts: 2863
  • Thank you received: 807
On Raspbian, all the astrophotography software needs to be built from scratch since there isn't anything like the PPA for Raspbian and the software in the package managers for Debian which Raspbian is built on is way out of date. From what you posted here, it sounds like you built a good deal of the software most likely. Did you have any information about any errors that might have printed to the console? It is possible that it all built perfectly and you just didn't get any icons for running it on the desktop. Maybe something about the Desktop on Raspbian has changed?
9 months 3 weeks ago #90253

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
It took well over an hour for the Pi to run the script through, or whatever it did do. But I guess that stuff was built, and it did not only set up the folders.
I did quickly look through of everything written in the terminal, but given that there were probably thousands of rows and I actually did not really not know what to look for there could very well possible be tons of problem that I missed. Is it possible everything stated in the terminal while running the script is saved somewhere so that one can look through it afterwards?

Sure, it is possible that it simply did not manage to create desktop shortcuts. If so, how do I create them myself?

I also have an SD card setup with Astroberry. So, for reference, I booted that up and looked where the kstars shortcut in Astroberry pointed to on the SD. The target folder was a folder called "application" which contained a type of object(again I do not know the proper terminology) for each of the programs installed in Astroberry, that is kstars, PHD2, internet browser and what not. The corresponding folder on my new installation had all the Raspbian regulars but all of the program that was supposed to be installed by the script were missing.

I am a Windows guy and pretty much completely Linux illiterate and I do not really have a clue how to proceed.
9 months 3 weeks ago #90257

Please Log in or Create an account to join the conversation.

  • Posts: 2863
  • Thank you received: 807
If it helps, my usual preference for my own system is to use Ubuntu Mate on the Pi, not Raspbian. With Ubuntu MATE, you can use the PPA and install everything in much simpler ways. I have another script on the Repo you used that handles ubuntu, and it is much simpler and takes much less time. On Raspbian, you have to build everything, and if you are not comfortable with diagnosing problems with building software or used to doing it, I would probably recommend the ubuntu route.
In terms of the Terminal Scrollback, if you didn't save it, then it is probably gone. I usually try to keep it open until I check that the installation worked before closing it. While it is still open, you can save it as a text file if needed.

If you want to check if the software installation worked, you could go to terminal and type kstars and see if it runs. If not, maybe go into the astroroot folder, look in the kstars-build folder and see if kstars was built there. if so, you could go there in terminal and try ./kstars to see if it runs.
9 months 3 weeks ago #90258

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
I have considered Ubuntu Mate for that very reason. What has been stopping me is that I have a device called Astrolink 4 Pi. It is a power distribution box, dew heater controller, housing my Raspberry Pi 4. For it to work, and to be able to control it, I need to install the INDI software for it, and the instructions that I have access to only is for either Astroberry or Stellarmate. And I do believe the Stellarmate instructions also work for any Raspbian Bullseye installation. But again, I may even have got that part wrong. The instructions and software for the device can be found at github . Perhaps it is not very difficult to get that running on Ubuntu Mate as well?

Let me explain why I am trying to do this in the first place. I have been using Astroberry before, a few crashes every session, but I have learned some things not to do, in order to not provoke the crashing and it has been working OK. But still, I considered going the Windows route instead, using my small Mele Quieter 3Q mini PC. Turned out I needed to upgrade the firmware of my Sesto Senso 2 in order to get that working with Ascom. Upgrading the firmware, in turn, broke the compatability with INDI for the focuser in Astroberry. New INDI drivers have been released that reinstates have been released. Astroberry, which is a bit behind now, have not had these new drivers added, hence I have been looking for other options. I have not getting everything I need for going Windows yet, so I need to use the Astrolink 4 Pi for a while still.

Followed that advice of yours, I could not get anything to run. The kstars-bulid folder is quite small. a few hundred KB and only a couple of objects. I feel like there should be more there?
9 months 3 weeks ago #90260

Please Log in or Create an account to join the conversation.

  • Posts: 2863
  • Thank you received: 807
So the Astroberry, StellarMate, and the software built with my script is all pretty much the same from an astronomy point of view. They all have INDI installed including various drivers, as well as KStars and sometimes other software. You can use INDI/KStars on Raspbian, Ubuntu MATE, or other Linux systems. Astroberry uses Raspbian and StellarMate uses Ubuntu. My script can try to set up either system, but it does require some knowledge in order to decide which parts of the script you would like to use and which parts you can comment out. Also, since not all systems are the same, some issues could be encountered.

As for whether they are up to date, Astroberry, since it is an image with everything installed, could easily be out of date after some time goes by. But I assume that there is some system in Astroberry to update INDI or other software periodically. It is Raspbian, so I don't think it can use the PPA, so I don't know how that software gets updated. StellarMate is based on Ubuntu, so it almost certainly has the PPA installed, so updating indi or kstars to the latest version is pretty simple with just two commands. As for my scripts, if you use an Ubuntu-Mate installation and the script I have for setting that one up, then it uses the PPA as well. I include scripts for updating, or you can just use the update commands I mentioned earlier. If you use Raspbian with my script, then to update it, you could run my update script, but that does involve rebuilding the latest versions.

It sounds to me like you encountered some sort of issue in the build if the kstars-build folder is small. It is not that small. My recommendation to you probably would be to either use StellarMate OS on your PI, or maybe try Ubuntu Mate and run my other script? I would be glad to help you try to find out what went wrong with your Raspbian run, but it sounds like you don't have any info about what happened during the build.
9 months 3 weeks ago #90293

Please Log in or Create an account to join the conversation.

  • Posts: 34
  • Thank you received: 1
I do not think Stellarmate is based on Ubuntu any more. Seems like it used to be, but since 1.5.0 it has been based on Raspbian, as mentioned here .

I now have tried out Ubuntu Mate, fetching Kstars/ekos/INDI worked very well there using the PPA. However, as I need to control it remotely, I installed VNC, and it was an extremely sluggish experience. This coupled with me being unable to use the previously mentioned instructions for getting the INDI drivers for my Astrolink 4 Pi up and running, I feel like this is yet another trench that I don't have the competency or patience to dig myself out of. Is there a prefered way to remotely operate an RPI running ubuntu mate that is not super slow? As the INDI drivers for the Astrolink 4 Pi only is coupled with instructions for Astroberry and Stellarmate, could it be the case that the drivers do not work on Ubuntu Mate? Would they need to be modified? Do I need to have the maker of the Astrolink make modifications on the drivers for it to support Ubuntu Mate?
9 months 2 weeks ago #90350

Please Log in or Create an account to join the conversation.

  • Posts: 2863
  • Thank you received: 807
I will have to ask Jasem about this, I don't know why he would have switched to Raspbian. I thought he was pretty well set on using Ubuntu, especially because he runs the PPA and it only works on Ubuntu.

For VNC control, there are numerous programs for running that and some are faster than others. I personally have used RealVNC myself, but others seem to prefer others and say they are faster. StellarMate uses noVNC I think.

Note that you don't have to do imaging or astrophotography over VNC, you can connect your PI and connect from your laptop computer running KStars. The PI can host the INDIServer and you connect to it from KStars on the laptop. this method is not sluggish at all. It is almost always the way I control my equipment. The only time I run the whole imaging session on the Pi and just connect via VNC is when I want to have it be fully automated and turn off my laptop computer. But if you have other computers lying around where you are observing, then no need for using VNC.
The following user(s) said Thank You: Tom
9 months 2 weeks ago #90523

Please Log in or Create an account to join the conversation.

  • Posts: 883
  • Thank you received: 84
I just got myself a Mele 3Q mini PC.
Installed Ubuntu Mate 22.04 and used Rob's script to install the stuff.
All went smoothly and all seems to be in place.

However, I cannot connect to Mele remotely over VNC.
When I try to connect with UltraVNC, Mele (x11vnc) asks me for a password but doesn't take any.

How to configure x11vnc correctly?
Can someone please help me!
I never used x11vnc before.

Max S.

MeLe 3Q x 2 with Stellarmate X.
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS D1 clip-in filter)
ASI2600MC Pro, ZWO ASI120MM Mini x 2
ZWO 30F4, Orion 50 mm f/3.2
Last edit: 9 months 1 week ago by maxthebuilder.
9 months 1 week ago #90696

Please Log in or Create an account to join the conversation.

  • Posts: 1134
  • Thank you received: 525

Replied by Hy Murveit on topic AstroPi3 Scripts revised

Just googled x11vnc password and came up with this link which claims your password might be ubuntu


In any case, assuming that's correct, you should go through the effort to change your vnc password to something more secure.

Here's another one that shows how to set your password

AP1100 mount, GSO RC10 mount w/RSF focus, ZWO ASI1600 imager & guider, Astronomik Filters, ONAG.
KStars/Ekos/Indi on NUC10 with Ubuntu 22.04
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
9 months 1 week ago #90699

Please Log in or Create an account to join the conversation.

Time to create page: 0.653 seconds