×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Sky Watcher ALT-AZ driver does not work.

  • Posts: 379
  • Thank you received: 26
Yes, I understand that you are a user.

I have been using INDI for 4 years.

The evolution in the meantime was amazing.

However, I also feel that there are improvements due to repeated updates.

I have a lot of information and distributions about INDI on my blog.

The blog also mentions notes about INDI, so please have a look if you have time.

tstudioastronomy.blog.fc2.com/blog-category-3.html

tstudioastronomy.blog.fc2.com/blog-category-31.html
1 year 5 months ago #65777

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 16
@T-Studio: Thanks, I will look at it this afternoon. I may get involved with the KStars handbook update shortly it would be good to review that kind of change detail.

Take a look at the thread: indilib.org/forum/general/6762-indiserve...or-synscan-goto.html
It contains a running dialog of testing and changes made by some of the programmers working on this particular driver along with some of my testing and results.
SkyWatcher 10" SynScan Goto Dobsonian, SV106 Guide, ZWO ASI178MC, Svbony SV105, SV305, Pi3HQcam, Pi4, DIY WaveShare focuser, Linux Ubuntu, KStars/Ekos, Carte du Ciel/CCDCiel, AstroDMx_Capture, Siril, StarTools, GIMP
1 year 5 months ago #65778

Please Log in or Create an account to join the conversation.

  • Posts: 84
  • Thank you received: 5
I would very much like to test the latest version of the Alt-Az driver. I am running astroberry on a pi4/4gb. I did install the latest indi driver according to the instruction on github.com/indilib/indi. When I start the driver via ekos, it does show version 1.2 in the "connection" tab, so I assume I have the latest version.
My mount is an Az-Eq6. I tried two variations to connect the mount: via usb cable (I have the most recent motor controller interface with a built-in usb; for that I have to choose 115 kbaud) and via bluetooth dongle (i.e. rfcomm with 9.6 kbaud) both variants will not connect. Does anybody give advice ?
Many thanks !
1 year 5 months ago #66531

Please Log in or Create an account to join the conversation.

  • Posts: 379
  • Thank you received: 26
tstudioastronomy.blog.fc2.com/blog-entry-391.html

I've put together a workaround for the bug on my blog.

Please convert it with a translation engine and check it.
1 year 5 months ago #66540

Please Log in or Create an account to join the conversation.

  • Posts: 84
  • Thank you received: 5
@T-Studio: first off, many thanks for your reply. I tried to follow the instructions from the web-page reference (the translation worked remarkably well), but it did not solve my problem. My mount will not even connect physically to the driver. This is the feedback I receive in the Ekos window:

2021-01-27T11:11:29 Skywatcher Alt-Az is disconnected.
2021-01-27T11:09:18 INDI services started on port 7624. Please connect devices.
2021-01-27T11:09:18 Starting INDI services...

Did anybody manage to connect the Az-Eq6 to this driver ? If so, by what means ? Do I have to connect via the HC in PC mode ? I took from the discription on the indi site ( indilib.org/telescopes/skywatcher/skywat...lt-az-dobsonian.html ; which is indeed the only reference there to the alt-az driver) that I can/should connect the mount directly to my raspberry (as with the EQmod, which runs flawlessly).
Any hints welcome !
Many thanks !
1 year 5 months ago #66552

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 16
I don't have the same mount exactly, but there should be three options for SynScan devices:
1 - Connect to the HC in PC Direct mode via USB-A (printer) cable. Getting the correct USB port designation is important.
2 - Connect via WiFi to the Motor Controller
3 - Use the indi_synscan_telescope driver and connect to the mount via tablet/phone running the SynScan.app and from the indi driver to the app all over WiFi.

There is a more recent version on github, but you will have to compile it. Although, I am not certain the version number is different, it has a variety of updates and fixes.
SkyWatcher 10" SynScan Goto Dobsonian, SV106 Guide, ZWO ASI178MC, Svbony SV105, SV305, Pi3HQcam, Pi4, DIY WaveShare focuser, Linux Ubuntu, KStars/Ekos, Carte du Ciel/CCDCiel, AstroDMx_Capture, Siril, StarTools, GIMP
1 year 5 months ago #66562

Please Log in or Create an account to join the conversation.

  • Posts: 84
  • Thank you received: 5
Jon,
many thanks, your help is very much appreciated. The Az-Eq 6 does not have any wifi capabilities. My options to connect are either through the built-in usb port (works well with EQmod @115 kbaud), via the usb port of the HC (@ 9600 baud) or via a bluetooth dongle, which is inserted into the MC unit instead of the HC.
I have just changed my setup to the most recent stable version of Stellarmate, in the hope of having newer drivers.
Again, the version of my driver is 1.2. From browsing through the code of "skywatcherAPI" on github (github.com/indilib/indi/commit/aeba92ac6...b96cd00d41f17c2f1359) I did understand that version 1.2 does include the most recent changes. Anyway, yesterday I did compile the most recent version on my Astroberry and it did also gave me version 1.2 of the Skywatcher Alt-Az driver. However, the response was the same as it is with Stellarmate. I enabled logging. This came out, when trying to connect via the HC @ 9600 baud:
[2021-01-27T15:54:29.472 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Connecting to /dev/ttyUSB0 @ 9600 "
[2021-01-27T15:54:29.477 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Port FD 3 "
[2021-01-27T15:54:29.477 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Connection successful, attempting handshake... "
[2021-01-27T15:54:29.477 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[SCOPE] SkywatcherAPIMount::Handshake "
[2021-01-27T15:54:29.478 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[SCOPE] InitMount "
[2021-01-27T15:54:29.478 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[SCOPE] CheckIfDCMotor "
[2021-01-27T15:54:31.494 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[SCOPE] SkywatcherAPIMount::Handshake - Result: 0 "
[2021-01-27T15:54:31.495 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Handshake failed. "
[2021-01-27T15:54:31.760 CET DEBG ][ org.kde.kstars.ekos] - "Skywatcher Alt-Az" is disconnected.
[2021-01-27T15:54:31.761 CET INFO ][ org.kde.kstars.ekos] - "Skywatcher Alt-Az is disconnected."

Same result when trying to connect through the built-in usb (which works flawlessly with EQmoc):
[2021-01-27T15:57:34.413 CET INFO ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[INFO] Scan complete. Found 1 port(s). "
[2021-01-27T15:57:39.177 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Connecting to /dev/ttyUSB0 @ 115200 "
[2021-01-27T15:57:39.187 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Port FD 3 "
[2021-01-27T15:57:39.188 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Connection successful, attempting handshake... "
[2021-01-27T15:57:39.188 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[SCOPE] SkywatcherAPIMount::Handshake "
[2021-01-27T15:57:39.189 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[SCOPE] InitMount "
[2021-01-27T15:57:39.189 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[SCOPE] CheckIfDCMotor "
[2021-01-27T15:57:41.194 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[SCOPE] SkywatcherAPIMount::Handshake - Result: 0 "
[2021-01-27T15:57:41.195 CET DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Handshake failed. "
[2021-01-27T15:57:41.300 CET DEBG ][ org.kde.kstars.ekos] - "Skywatcher Alt-Az" is disconnected.
[2021-01-27T15:57:41.301 CET INFO ][ org.kde.kstars.ekos] - "Skywatcher Alt-Az is disconnected."

I remember having a similar problem last year prior to the revision of the Skywatcher Alt-Az driver. Apparently the Az-Eq 6 gives a response during the handshake process which is not anticipated by the driver.
Any ideas ?
Cheers and kind regards
Dirk
1 year 5 months ago #66566

Please Log in or Create an account to join the conversation.

  • Posts: 215
  • Thank you received: 16
I'll take a look at the driver tomorrow and see if I can sort out what it expects. It is looking for a 1 rather than 0. Perhaps the programmer who made some of the changes recently will have some useful input. I will try to contact him. Though, you may be correct and even if the handshake is adjusted and succeeds there may be other issues beyond the handshake if the firmware in the motors is that different.
SkyWatcher 10" SynScan Goto Dobsonian, SV106 Guide, ZWO ASI178MC, Svbony SV105, SV305, Pi3HQcam, Pi4, DIY WaveShare focuser, Linux Ubuntu, KStars/Ekos, Carte du Ciel/CCDCiel, AstroDMx_Capture, Siril, StarTools, GIMP
Last edit: 1 year 5 months ago by Jon Carleton.
1 year 5 months ago #66577

Please Log in or Create an account to join the conversation.

  • Posts: 84
  • Thank you received: 5
Many thanks, Jon. I looked up the issue I had last year. Here is the link to the conversation: indilib.org/forum/wish-list/7524-alt-az-...-eqmod.html?start=24
Apparently the `CheckifDCMotor` routine uses commands the Az-Eq 6 does not understand. The reply of my mount is "!0", which is apparently an error code. Jean-Luc Geehalel did test the driver back then with his Az-Eq 5 and received an error code "!1".
I checked the response of my mount with picocom according to the instructions from Jean-Luc. Unfortunately I never managed to compile the code from his indi branch correctly. Hope we can solve it this time...
1 year 5 months ago #66578

Please Log in or Create an account to join the conversation.

  • Posts: 84
  • Thank you received: 5
Hmm, I tried again to understand what is happening: the way I read it, the handshake process with my mount is broken off after the "check if dc motor" routine. My mount does not have DC motors, but stepper motors, hence the "!0" response. Peeking at the further code of the driver, it seems to be capable of controlling stepper motors. I guess the code needs to be changed so that the handshake process continues with a "false" for the "dc motor" variable...
1 year 5 months ago #66582

Please Log in or Create an account to join the conversation.

  • Posts: 84
  • Thank you received: 5
I looked further into the code, although I do not really understand, how it does work. I made a local clone of the indi core and want to change the skywatcherAPI.cpp so it will return the "IsDCMotor" variable as "false" (without even checking; so just plain setting of the variable). I also noticed that in the code of the skywatcherAPI.h the MountType for the Az-Eq 6 is missing. From looking into the code of the eqmod driver I understand the MountType for the AZEQ6 should be "0x05". So could I just enter a line under enum MountType (eg 271) reading "AZEQ6 = 0x05," ?
Any help is very much appreciated !
1 year 5 months ago #66597

Please Log in or Create an account to join the conversation.

  • Posts: 84
  • Thank you received: 5
@JonCarleton: meanwhile I did follow up to this topic: indilib.org/forum/wish-list/7524-alt-az-...-eqmod.html?start=48
Jean-Luc back then provided some modified code of the skywatcherAPI, which is supposed to solve the problem of the error response:
}
// AZEQ5 replies error code '!1', AZEQ6 replies error code '!0'
if ((TTY_TIME_OUT == rc) || ((2 == nbytes) && ('!' == input[0]) && (('0' == input[1]) || ('1' == input[1]))))
{
IsDCMotor = false;
return true;
}

He also added some lines to take care of the MountCode of the AZEQ6 (0x06 is the code for the AZEQ5, I believe)
bool SkywatcherAPI::IsAZEQMount() const
{
return MountCode == 0x05 || MountCode == 0x06;
}

Still, even with this version of the driver, the response of my mount remains:
[2021-01-28T15:25:21.474 W. Europe Standard Time DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Toggle Debug Level -- Scope Verbose "
[2021-01-28T15:25:23.594 W. Europe Standard Time DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Connecting to /dev/ttyUSB0 @ 115200 "
[2021-01-28T15:25:23.640 W. Europe Standard Time DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Port FD 3 "
[2021-01-28T15:25:23.651 W. Europe Standard Time DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Connection successful, attempting handshake... "
[2021-01-28T15:25:23.662 W. Europe Standard Time DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[SCOPE] SkywatcherAPIMount::Handshake "
[2021-01-28T15:25:23.674 W. Europe Standard Time DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[SCOPE] InitMount "
[2021-01-28T15:25:23.685 W. Europe Standard Time DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[SCOPE] CheckIfDCMotor "
[2021-01-28T15:25:25.608 W. Europe Standard Time DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[SCOPE] SkywatcherAPIMount::Handshake - Result: 0 "
[2021-01-28T15:25:25.658 W. Europe Standard Time DEBG ][ org.kde.kstars.indi] - Skywatcher Alt-Az : "[DEBUG] Handshake failed. "
[2021-01-28T15:25:25.719 W. Europe Standard Time DEBG ][ org.kde.kstars.ekos] - "Skywatcher Alt-Az" is disconnected.

As far as I understand the internal workings (i.e. MC unit) of the AZEQ6 and AZEQ5 are quite similar. Since Jean-Luc got his AZEQ5 working with the skywatcher_AltAz, I assume there remain only minor issues to be resolved. I am quite eager to test anything, but I came as far as I can with my own abilities. Hope, someone can help !
Last edit: 1 year 5 months ago by Dirk Tetzlaff.
1 year 5 months ago #66607

Please Log in or Create an account to join the conversation.

Time to create page: 0.836 seconds