×

INDI Library v1.9.2 Released (14 Sep 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones.

StellarMateOS on ASIAir Pro hardware

  • Posts: 140
  • Thank you received: 9
Hello,

I have both the StellarMateOS and an ASIAir Pro appliance.  I love the form factor of the ASIAir Pro but miss the lack of vendor support for focusers and accessories.  I am pretty sure the StellarMateOS will work on the ASIAir Pro hardware but I think the 4 12v power ports would either be unusable or non-configurable under StellarMateOS.  Since one of my setups has a Moonlite focuser and Xagyl filter wheels, I was wondering if there was some way to enable the use of those integrated power ports in the ASIAir Pro with StellarMate OS installed.  I can certainly live without the capability and I could control the power directly if needed, but it would be convenient if it could be done via StellarMate.

My questions are::

1 - Is it confirmed that StellarMateOS will run on the ASIAir Pro?  I understand it would not be 'supported' per se but I wanted to make sure it would in fact work.

2 - Is there any way to configure StellarMateOS to recognize and control the integrated 12v power ports on the ASIAir Pro?  I suspect that the ASIAir probably has some config.txt foo that enables the ports via the GPIO but am unsure if this is the case. 

Any input on this would be appreciated.
3 months 1 day ago #73643

Please Log in or Create an account to join the conversation.

  • Posts: 1146
  • Thank you received: 202
I believe a driver already exists for it called ASI Power.

Edit.

I also found it can be enabled by adding a few lines to your /boot/config.txt file
#Enable 12v gpio output
gpio=18,12,13,26=op,dh,pu
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
Last edit: 2 months 1 week ago by Andrew.
2 months 1 week ago #74248

Please Log in or Create an account to join the conversation.

  • Posts: 260
  • Thank you received: 46
Wow I had no idea this was possible!

Can ASIAir Pro run generic ubuntu/KStars? Or just StellarMate?
2 months 1 week ago #74250

Please Log in or Create an account to join the conversation.

  • Posts: 32
  • Thank you received: 0
Should really be the same. Running just Kstars on my laptop is just like my StellarMate on RPi4
2 months 1 week ago #74328

Please Log in or Create an account to join the conversation.

  • Posts: 140
  • Thank you received: 9
Thanks for the replies guys. Does anything have to be modified to use the ASIPower driver? I seem to recall something about some config.txt modification in the past that may have been necessary to get the power ports functional under standard linux on the Pi. Not sure if this applies to the StellarMateOS version though.
2 months 1 week ago #74334

Please Log in or Create an account to join the conversation.

  • Posts: 140
  • Thank you received: 9
Duh. I just saw you posted it right in your reply. Guess I should read more closely. :)
2 months 1 week ago #74335

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0
I am trying a different thing, but similar.

I tried to use Astroberry on the ASIAIR PRO. I installed the ASI-Power driver and changed the config.txt as mentioned.

But ASI Power crashes. What am I doing wrong?
1 month 3 weeks ago #74931

Please Log in or Create an account to join the conversation.

  • Posts: 1146
  • Thank you received: 202
The driver could be out of date and needs to be recompiled with the latest indilib. I suggest reaching out to Radek Kaczorek about such issues with Astroberry, or leave a post on the Astroberry section of the forum. www.indilib.org/forum/astroberry.html
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
1 month 3 weeks ago #74959

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 0
Thank you for the hint.

I tried several things to compile the driver...

sudo apt-get -y install libnova-dev libcfitsio-dev libusb-1.0-0-dev zlib1g-dev libgsl-dev build-essential cmake git libjpeg-dev libcurl4-gnutls-dev libtiff-dev libfftw3-dev libftdi-dev libgps-dev libraw-dev libdc1394-22-dev libgphoto2-dev libboost-dev libboost-regex-dev librtlsdr-dev liblimesuite-dev libftdi1-dev libavcodec-dev libavdevice-dev
[sudo] password for astroberry:
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version (12.6).
git is already the newest version (1:2.20.1-2+deb10u3).
libcfitsio-dev is already the newest version (3.450-3).
libcfitsio-dev set to manually installed.
libnova-dev is already the newest version (0.16-4).
libnova-dev set to manually installed.
libusb-1.0-0-dev is already the newest version (2:1.0.22-2).
libusb-1.0-0-dev set to manually installed.
zlib1g-dev is already the newest version (1:1.2.11.dfsg-1).
zlib1g-dev set to manually installed.
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
cmake : Depends: cmake-data (= 3.16.3-3~bpo10+1) but it is not going to be installed
Depends: libjsoncpp1 (>= 1.7.4) but it is not going to be installed
Depends: librhash0 (>= 1.2.6) but it is not going to be installed
indi-asi-power : Depends: libpigpiod but it is not going to be installed
libavcodec-dev : Depends: libavcodec58 (= 7:4.1.6-1~deb10u1+rpt2)
Depends: libavutil-dev (= 7:4.1.6-1~deb10u1+rpt2) but it is not going to be installed
Depends: libswresample-dev (= 7:4.1.6-1~deb10u1+rpt2) but it is not going to be installed
libavdevice-dev : Depends: libavdevice58 (= 7:4.1.6-1~deb10u1+rpt2) but 7:4.1.6-1~deb10u1+rpt1 is to be installed
Depends: libavfilter-dev (= 7:4.1.6-1~deb10u1+rpt2) but it is not going to be installed
Depends: libavformat-dev (= 7:4.1.6-1~deb10u1+rpt2) but it is not going to be installed
Depends: libavutil-dev (= 7:4.1.6-1~deb10u1+rpt2) but it is not going to be installed
Depends: libpostproc-dev (= 7:4.1.6-1~deb10u1+rpt2) but it is not going to be installed
Depends: libswscale-dev (= 7:4.1.6-1~deb10u1+rpt2) but it is not going to be installed
Depends: libswresample-dev (= 7:4.1.6-1~deb10u1+rpt2) but it is not going to be installed
libboost-dev : Depends: libboost1.67-dev but it is not going to be installed
libboost-regex-dev : Depends: libboost-regex1.67-dev but it is not going to be installed
libcurl4-gnutls-dev : Depends: libcurl3-gnutls (= 7.64.0-4+deb10u2) but 7.64.0-4+deb10u1 is to be installed
libdc1394-22-dev : Depends: libraw1394-dev but it is not going to be installed
libfftw3-dev : Depends: libfftw3-bin (= 3.3.8-2) but it is not going to be installed
libftdi-dev : Depends: libusb-dev (>= 0.1.11) but it is not going to be installed
libgphoto2-dev : Depends: libexif-dev but it is not going to be installed
Depends: libgphoto2-6 (= 2.5.27) but 2.5.24-1 is to be installed
libgps-dev : Depends: libgps23 (= 3.17-7+b1) but 3.17-7 is to be installed
libjpeg-dev : Depends: libjpeg62-turbo-dev (>= 1:1.5.2-2+deb10u1) but it is not going to be installed
liblimesuite-dev : Depends: liblimesuite18.06-1 (= 18.06.0+dfsg-1+b1) but it is not going to be installed
libraw-dev : Depends: liblcms2-dev but it is not going to be installed
librtlsdr-dev : Depends: librtlsdr0 (= 0.6-1+rpt1) but it is not going to be installed
libtiff-dev : Depends: libjbig-dev but it is not going to be installed
Depends: liblzma-dev but it is not going to be installed
Depends: libtiff5 (= 4.1.0+git191117-2~deb10u2) but 4.1.0+git191117-2~deb10u1 is to be installed
Depends: libtiffxx5 (= 4.1.0+git191117-2~deb10u2) but 4.1.0+git191117-2~deb10u1 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).


Next try:
sudo apt -y install libpigpiod
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
libpigpiod
0 upgraded, 1 newly installed, 0 to remove and 383 not upgraded.
1 not fully installed or removed.
Need to get 0 B/113 kB of archives.
After this operation, 424 kB of additional disk space will be used.
(Reading database ... 158610 files and directories currently installed.)
Preparing to unpack .../libpigpiod_0.2-1_armhf.deb ...
Unpacking libpigpiod (0.2-1) ...
Replacing files in old package pigpiod (1.71-0~rpt1) ...
dpkg: error processing archive /var/cache/apt/archives/libpigpiod_0.2-1_armhf.deb (--unpack):
trying to overwrite '/usr/include/pigpio.h', which is also in package libpigpio-dev 1.71-0~rpt1
Errors were encountered while processing:
/var/cache/apt/archives/libpigpiod_0.2-1_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Last try:


sudo apt -y install libpigpiod-if-dev libpigpiod-if2-1 pigpio-tools libpigpiod
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libpigpiod-if-dev : Depends: libpigpiod-if1 (= 1.79-1+rpt1) but 1.71-0~rpt1 is to be installed
pigpio : Depends: libpigpiod-if2-1 (= 1.71-0~rpt1) but 1.79-1+rpt1 is to be installed
Depends: libpigpiod-if-dev (= 1.71-0~rpt1) but 1.79-1+rpt1 is to be installed
Depends: pigpio-tools (= 1.71-0~rpt1) but 1.79-1+rpt1 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
Weird...
Last edit: 1 month 3 weeks ago by Karsten Buxtehude.
1 month 3 weeks ago #74969

Please Log in or Create an account to join the conversation.

Time to create page: 0.246 seconds