×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Ioptron CEM 40 unable to connect

5 months 18 hours ago
lemmu
Junior Boarder
Junior Boarder
Posts: 27
More
Topic Author
Ioptron CEM 40 unable to connect #40864
Hello,
Just got my CEM 40 . Today I tried to connect via USB directly to stellarmate using cem 120 and cem 60 drivers. Timed out and does not recognize any. Any ideas or thoughts? Fellow cem 40 owners, are you here?

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
Highkamp
Fresh Boarder
Fresh Boarder
Posts: 10
More
Ioptron CEM 40 unable to connect #40928
Try connecting through the hc. I could not connect my cem120 directly using usb to mount but could when I used hc.

Please Log in or Create an account to join the conversation.

4 months 4 weeks ago
dokeeffe
Platinum Boarder
Platinum Boarder
Posts: 378
More
Ioptron CEM 40 unable to connect #40929
Maybe try change the baud rate in the indi driver settings. I had to change this to connect direct to my CEM120. I set it to the second highest one 11520

Celestron CPC1100 Atik 383L
HP8300 Elite i5 running Xubuntu, Indi, Kstars & Ekos
Roll off roof observatory
Battling Irish weather
github.com/dokeeffe
twitter.com/BallyhouraStars

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago
lemmu
Junior Boarder
Junior Boarder
Posts: 27
More
Topic Author
Ioptron CEM 40 unable to connect #40931
Tried both ways. baud rate and via HC . Still no good.Log file is pretty much meaningless.

File Attachment:

File Name: cem120.txt
File Size:1 KB
Attachments:

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago
dokeeffe
Platinum Boarder
Platinum Boarder
Posts: 378
More
Ioptron CEM 40 unable to connect #40932
I see this in the log file
`iOptron CEM120\nPlease ensure remote device name corresponds to actual device name`

But you are using a CEM 40?

Celestron CPC1100 Atik 383L
HP8300 Elite i5 running Xubuntu, Indi, Kstars & Ekos
Roll off roof observatory
Battling Irish weather
github.com/dokeeffe
twitter.com/BallyhouraStars

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago
AstroNerd
Moderator
Moderator
Posts: 676
Karma: 1
More
Ioptron CEM 40 unable to connect #40933

Highkamp wrote: Try connecting through the hc. I could not connect my cem120 directly using usb to mount but could when I used hc.


The CEM 60 and the 120 are supposed to connect direct to a PC using a special serial to USB cable, connected to the rs232 port on the mounts, not via direct USB, the CEM 40 is different..

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago 4 months 3 weeks ago by dokeeffe.
dokeeffe
Platinum Boarder
Platinum Boarder
Posts: 378
More
Ioptron CEM 40 unable to connect #40934
I can connect to my CEM120 via direct USB. Seems to work fine.

If the CEM40 has the same serial command set as other mounts (good chance it does). Then in theory you could just add it to the models map here
github.com/indilib/indi/blob/master/libi.../ioptronv3driver.cpp
Actually you'll also need to add an entry to the drivers.xml
Then rebuild indi locally and test it.

Celestron CPC1100 Atik 383L
HP8300 Elite i5 running Xubuntu, Indi, Kstars & Ekos
Roll off roof observatory
Battling Irish weather
github.com/dokeeffe
twitter.com/BallyhouraStars

Please Log in or Create an account to join the conversation.

4 months 3 weeks ago
lemmu
Junior Boarder
Junior Boarder
Posts: 27
More
Topic Author
Ioptron CEM 40 unable to connect #40936
There i9s no CEM 40 option so far in SM

Please Log in or Create an account to join the conversation.

4 months 1 week ago
sbernd78
Fresh Boarder
Fresh Boarder
Posts: 8
More
Ioptron CEM 40 unable to connect #41382
Hi.

Today I got my CEM40 to.
With the direct USB-Connection I can connect to the Mount (first I have to plug it in the running Computer and than switch the Mount on).
I can connect with the iOptronV3-Driver. But it did not work full.
In this Image you can see the problems. The connection is opened but the communication is not working completely.

It seems there are some issues with the response-data from the Mount. But I'm not smart enough for programming this stuff.

Greetings
Bernd
Attachments:

Please Log in or Create an account to join the conversation.

4 months 1 week ago
lemmu
Junior Boarder
Junior Boarder
Posts: 27
More
Topic Author
Ioptron CEM 40 unable to connect #41383
Hi,
Good to know I'm not alone anymore with same issue, We should wait few weeks. Jaseem promised create new driver.
The following user(s) said Thank You sbernd78

Please Log in or Create an account to join the conversation.

4 months 1 week ago
DerPit
Gold Boarder
Gold Boarder
Posts: 276
Karma: 1
More
Ioptron CEM 40 unable to connect #41385
+1, I have the same issue using that driver with the CEM60

openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+ASI290 mini

Please Log in or Create an account to join the conversation.

4 months 1 week ago
sbernd78
Fresh Boarder
Fresh Boarder
Posts: 8
More
Ioptron CEM 40 unable to connect #41392
Thank you.
I hoped, I could use the full equipment next weekend. ;-)
But I think, I have to work with Windows for this first tour.

Greetings.

Please Log in or Create an account to join the conversation.

Time to create page: 0.768 seconds