×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Stellarmate vnc black screen problem

2 months 2 weeks ago
khobar
Senior Boarder
Senior Boarder
Posts: 49
More
Topic Author
Stellarmate vnc black screen problem #44052
I have Stellarmate on a Raspberry Pi4 I've been building up, and now something has gone amiss. I was trying to set the Stellarmate up so it would be on my home network and thus see the Internet and get updates, etc. I was in Stellermate app and changed the setting from "Hotspot" to "Infrastructure" but was confounded by the device's refusal to scan for SSID's to join. I tried it inside where it's closer, and same thing. But I made the mistake of closing the VNC session in that mode.

Today, I connected the Stellarmate to the wired network, and checked my router, and there it is - twice. But while I can "connect" to either the wired or wireless IP, I get nothing but a black screen. I tried the other IP and same result.

Is there anything I can do?

Thanks!

Please Log in or Create an account to join the conversation.

2 months 2 weeks ago
AstroNerd
Moderator
Moderator
Posts: 694
Karma: 1
More
Stellarmate vnc black screen problem #44054
Hi and welcome,
You should not change the hotspot setting to connect to to your home network, just connect to the rpi with a network cable, then go in and connect the internal WiFi to you network as you would on any other computer..then when the rpi boots up, it will look for that wifi network first and connect, and then if it can’t find, it will create the hotspot, if you need to use the hotspot and another connection to your home WiFi at the same time, you then need another WiFi USB dongle...
No need to change any settings at all.. :)

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes
The following user(s) said Thank You khobar

Please Log in or Create an account to join the conversation.

2 months 2 weeks ago
khobar
Senior Boarder
Senior Boarder
Posts: 49
More
Topic Author
Stellarmate vnc black screen problem #44058
Arg!

Thanks for the quick reply. If I understand you correctly, now that I've gone in with ethernet and configured wireless to see my wifi network, the rpi will default to joining that network, and if it can't, will then go into hotspot mode? That is exactly what I'd like!

I'm guessing the black screen was caused by user error. Maybe something got corrupted. I ended up flashing a new microSD card and starting from scratch - won't hurt me learning how to configure things and get the GPS in UART mode over again. ;) VNC is working again, though for some reason the rpi's wifi had been turned *off*.

Thanks again for the quick reply. All the best and clear skies to you.

Please Log in or Create an account to join the conversation.

2 months 1 week ago
AstroNerd
Moderator
Moderator
Posts: 694
Karma: 1
More
Stellarmate vnc black screen problem #44068
Yes, leave the hotspot as is, and just connect a second connection to your home WiFi, the rpi then will look for that first, and after a set time if it does not find, it will start the hotspot for you to connect too, this is the default setting of this system...
Just click on the network icon, and then the networks will show up, click the one you want and put password in and away you go...same as a PC... :)

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes
The following user(s) said Thank You khobar

Please Log in or Create an account to join the conversation.

2 months 1 week ago
khobar
Senior Boarder
Senior Boarder
Posts: 49
More
Topic Author
Stellarmate vnc black screen problem #44160
Thank you again.

I must have buggered something along the way because my Pi4 doesn't see my home network. I can connect to "stellarmate" via my laptop, so I know the hardware is working.

After some reading, I thought maybe MAC filter was enabled on the router but it wasn't.

The rpi is currently attached to my mount outside on the patio about 10' from the router. I added a second WiFi adapter (USB) and it connects fine.

Please Log in or Create an account to join the conversation.

2 months 1 week ago
El Corazon
Platinum Boarder
Platinum Boarder
Posts: 430
Karma: 3
More
Stellarmate vnc black screen problem #44175

khobar wrote: I have Stellarmate on a Raspberry Pi4 I've been building up, and now something has gone amiss. I was trying to set the Stellarmate up so it would be on my home network and thus see the Internet and get updates, etc. I was in Stellermate app and changed the setting from "Hotspot" to "Infrastructure" but was confounded by the device's refusal to scan for SSID's to join. I tried it inside where it's closer, and same thing. But I made the mistake of closing the VNC session in that mode.

Today, I connected the Stellarmate to the wired network, and checked my router, and there it is - twice. But while I can "connect" to either the wired or wireless IP, I get nothing but a black screen. I tried the other IP and same result.

Is there anything I can do?

Thanks!



I also have the black screen problem, but only when I am in hotspot mode on the Pi4. However, it resolves within 3-4 min. It seems to me that the Pi4 needs extra time to boot up when in hotspot mode.

Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set

Please Log in or Create an account to join the conversation.

2 months 1 week ago
AstroNerd
Moderator
Moderator
Posts: 694
Karma: 1
More
Stellarmate vnc black screen problem #44181
No it’s doesn’t, mine works perfectly in both hotspot and on home WiFi, you have issues that are not related to the software I’m afraid... mine connects to home WiFi when it boots, and if home WiFi is not available, it starts the hotspot, and I connect to that...works every time.. :)

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

2 months 1 week ago
khobar
Senior Boarder
Senior Boarder
Posts: 49
More
Topic Author
Stellarmate vnc black screen problem #44183

AstroNerd wrote: No it’s doesn’t, mine works perfectly in both hotspot and on home WiFi, you have issues that are not related to the software I’m afraid... mine connects to home WiFi when it boots, and if home WiFi is not available, it starts the hotspot, and I connect to that...works every time.. :)


I've no doubt of this, and the FAQ confirms that's exactly how it's supposed to work, but for some reason mine can't see my network. I'll keep at it, and when I get a solution I'll post back.

@E Corazan - one thing I came across regarding the black screen is that *if* you have a USB keyboard, plug it into the pi and hit CTRL-D. That *might* help.

Please Log in or Create an account to join the conversation.

2 months 1 week ago
khobar
Senior Boarder
Senior Boarder
Posts: 49
More
Topic Author
Stellarmate vnc black screen problem #44184
Just out of curiosity, do you have an /etc/network/interfaces file that has your SSID and password info in it, or does it just have a reference to loopback?

Please Log in or Create an account to join the conversation.

2 months 1 week ago
AstroNerd
Moderator
Moderator
Posts: 694
Karma: 1
More
Stellarmate vnc black screen problem #44191
Which SM version are you using, I have the very latest KDE version...and if you click on the network icon top right of screen and then it should show all available networks, click you home WiFi, and enter password and that should be it...next time you boot up it should join it, and if it’s not available to join, it will auto start the hotspot...
you can also check in the settings of that connection and make sure the band is on auto and other settings too... I don’t see why this will not work for you

Stellarmate OS BETA on Raspberry pi4b
Skywatcher EQ8 pro
Meade series 5000 80mm triplet Apo & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar Guide Camera
Pegasus Ultimate Hub for all USB & Power
Pegasus focus motors on both scopes

Please Log in or Create an account to join the conversation.

2 months 6 days ago
khobar
Senior Boarder
Senior Boarder
Posts: 49
More
Topic Author
Stellarmate vnc black screen problem #44374
SM100.

Network "issue" persists. The onboard WiFi seems locked on Hotspot mode. Adding USB WiFi adapter allows me to see my internal network, but the Stellarmate cannot see the internet *until* I issue an "ifconfig wlan0 down". After that, the hotspot is disabled and all network traffic goes via wlan1.

I flashed a new 64GB microSD with the same OS and, *without any updates*, the Stellarmate switched from Hotspot to Infrastructure and I could access it on my home network.

I will continue working on it. Like I said, I probably buggered a config file somewhere along the line. In the meantime, I am pressing on as I have a date with (hopefully) much darker skies in a few days. :) :) :)

Please Log in or Create an account to join the conversation.

2 months 6 days ago
wvreeven
Platinum Boarder
Platinum Boarder
Posts: 1114
Karma: 6
More
Stellarmate vnc black screen problem #44384
My suspicion is that all traffic is routed via wlan0 because that one is enabled first and then wlan1. By then the default route has been set to use the wlan0 interface so deleting the default route and adding one for wlan1 should also solve the issue. It should also be possible to create a script that runs at some point and tries to detect if both wlan0 and wlan1 are up and have a valid ip address. If yes it could delete the default route and create it again for wlan1.

Another solution could be to try and see if the kernel modules for the two wlan devices can be given a priority so the current wlan1 kernel module gets loaded first so it will always get the default route. No idea if that really works because it probably also depends on how quickly your network assigns an ip address via dhcp.

And perhaps this can be configured via wpa-supplicant or so but I really wouldn’t know if that is possible at all.

Just a few thought that I hope may be useful to you.


Clear skies, Wouter

ASI1600MM-Pro Cooled and filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro

ASI1600MM-Pro Cooled and filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R

Please Log in or Create an account to join the conversation.

Time to create page: 0.638 seconds