×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

EKOS equipment manager with different focuser draw tube lengths

  • Posts: 527
  • Thank you received: 138
I have two equipment profiles. One for an RC6 with Moonlite focuser, and another for a 102mm APO with Moonlite focuser. Because the focusers are the same brand, I noticed that the driver under the equipment manager maintains the the same settings for either device as if it's the same device.

Where this causes me an issue is that the draw tube length on the APO is around 28,400 ticks on the stepper motor, and for the RC6 it's around 4,500. So, if I've been imaging with one and the max range is set to 4,500, then switch to the other is 28,400, I have to manually update the max range even though I'm loading a new profile. Is there any way to store the settings separately per profile?
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
3 years 5 months ago #27164

Please Log in or Create an account to join the conversation.

The quick way to do this is to edit the drivers XML file /usr/share/indi/drivers.xml
Then find the moonlight driver, like this:
<device label="MoonLite">
                <driver name="MoonLite">indi_moonlite_focus</driver>
                <version>1.0</version>
        </device>
Simply copy this and directly below it, add another driver, so you'll end up with something like this:
<device label="MoonLite RC6">
                <driver name="MoonLite">indi_moonlite_focus</driver>
                <version>1.0</version>
        </device>
<device label="MoonLite APO">
                <driver name="MoonLite">indi_moonlite_focus</driver>
                <version>1.0</version>
        </device>

So next time, you can select these drivers and once you save the config, they will be saved to different config files.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: Hellriegel, Jim, Bernd Limburg, Paul Muller
3 years 5 months ago #27168

Please Log in or Create an account to join the conversation.

  • Posts: 509
  • Thank you received: 102
Very handy, I have this exact same issue. Thanks!
12" pier with HDX110 using EQMod
ASI 1600 mono/color mains with ASI290MM in off-axis
ASI filter wheel
Moonlite focusers for the sharpening
AT115EDT w/.8x for the light
Fedora Linux, 100% INDI
3 years 4 months ago #27349

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 9
Today I struggled over that problem. I'm planning to buy a second Pegasus DMFC for my second scope. So I added the additional lines in the drivers.xml. When I work locally on my Raspi (with kstars 3.5.0) it works. I have three focusers to choose (the original one and two separate for my two scopes). I can have two different setups now, but only if I work locally.

My standard procedure is to work at my PC remotely on the Raspi. I also changed the drivers.xml at PC site, so I can choose the different focusers. I work over INDI hub. The problem now is, that I only can work with the original driver, doesn't matter what focuser I choose....

Due to that finding I get back to my Raspi and work there remote over INDI hub. Result is the same as on my PC: I only get the original focuser but not the separate ones, despite the fact that I can choose the seperate drivers from the list...

Do I have to change some other settings/files when working remotely?
11 months 6 days ago #65167

Please Log in or Create an account to join the conversation.

Try using the Driver Alias feature in Tools --> Devices --> Custom Drivers. Not sure if it will help with remote, but maybe start KStars on remote and use it there.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
11 months 5 days ago #65189

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 9
Thank you for the suggestion. Unfortunately that doesn't work. I tried it to have the same custom drivers on each pc/raspi, but I got always one setting... If I changed e.g. a presetting in the one custom driver it changes also the other...

I also found, that I have to use the INDI webmanager, maybe this is the reason it dont work?

Would be very nice if it would be possible to get this work, but at the moment I can live with that,
11 months 3 days ago #65345

Please Log in or Create an account to join the conversation.

  • Posts: 182
  • Thank you received: 23
Amazing! Such a simple idea, but effective!
GSO Ritchey Chretien 12" Truss | SkyWatcher ED72
ZWO ASI 2600MC Pro, 1600MM Pro, ASI290MM and ASI224MC all-sky | ZEO EFW | ZWO OAG
Moonlite V2.5 CSL | DeepSkyDad AF3
EQ8-R | Paramount ME & MX
Nexdome | SQM LE | AAG CloudWatcher and Solo | Ultimate Power Box V2 | Spike-a-Flat
Angry missus
10 months 3 weeks ago #65668

Please Log in or Create an account to join the conversation.

  • Posts: 60
  • Thank you received: 6
Hi,

I have to revive this old thread again, because the solutions doesn't work for me anymore.

I have Astroberry on RPi4 with 2 ZWO EAF focusers in 2 setups with differing maxpositions. In /usr/share/indi/indi_asi.xml I created 2 devices:

<devGroup group="Focusers">
        <device label="ASI EAF APO" manufacturer="ZWO">
                <driver name="ASI EAF APO">indi_asi_focuser</driver>
                <version>1.9</version>
        </device>
        <device label="ASI EAF Newton" manufacturer="ZWO">
                <driver name="ASI EAF Newton">indi_asi_focuser</driver>
                <version>1.9</version>
        </device>

</devGroup>

I even changed the driver name, not only the device label, but that made no difference. Every time I change the maxposition and save the configuration, only the file ~/.indi/ASI EAF_config.xml is updated. The 2 files ~/.indi/ASI EAF APO_config.xml and ~/.indi/ASI EAF Newton_config.xml remain unchanged (although they exist).

It worked before, but I didn't use Astroberry for several weeks. Yesterday, I updated all and had to modify /usr/share/indi/indi_asi.xml again, as described, because my previous change was gone.

Do I miss something, or am I doing something wrong?

CS, Bernd
10" F5 Newton and 130mm F7 Apo on EQ6-R, ZWO EAF focusers, ASI294MC Pro, ASI183MM, Astroberry on RPi4b, PixInsight
3 months 1 week ago #74754

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 9
Hi Bernd,
I changed the "drivers.xml" in /usr/share/indi (there is a section "Focusers"), the same way you did it for the indi_ASI.xml. That worked for me with the Pegasus DMFC.

The only thing is, that I have to renew it in the case of updates...
3 months 1 week ago #74755

Please Log in or Create an account to join the conversation.

  • Posts: 60
  • Thank you received: 6
Hi Juergen,

thanks for your reply. There is no ZWO EAF in drivers.xml, but I tried and moved the lines from indi_asi.xml to drivers.xml. But it's the same behavior then, changes always go into ~/.indi/ASI EAF_config.xml.
10" F5 Newton and 130mm F7 Apo on EQ6-R, ZWO EAF focusers, ASI294MC Pro, ASI183MM, Astroberry on RPi4b, PixInsight
3 months 1 week ago #74757

Please Log in or Create an account to join the conversation.

  • Posts: 75
  • Thank you received: 9
Hi Bernd,
there was a threat on astronomie.de, perhaps that helps (hope you speek german looking at your name...)? The guy there has also two EAF, he describes how to do it with ASI EAF. For him it works.

forum.astronomie.de/threads/indi-2-setup...303353/#post-1561804
3 months 1 week ago #74759

Please Log in or Create an account to join the conversation.

  • Posts: 60
  • Thank you received: 6
Yes, indeed I'm German and found this thread here via the thread on astronomie.de you posted  .

It is strange, because it worked before, until the updates yesterday...
10" F5 Newton and 130mm F7 Apo on EQ6-R, ZWO EAF focusers, ASI294MC Pro, ASI183MM, Astroberry on RPi4b, PixInsight
3 months 1 week ago #74763

Please Log in or Create an account to join the conversation.

Time to create page: 0.775 seconds