Make sure you have the latest firmware update. 1.5 I think is the most current. You have to update this through the Pegasus Software on a PC though. Once that's done. Plug in the USB into the Stellarmate, then reboot the StellarMate so that it properly detects plugged in devices. I do find with all the available ports, and lots of things plugged in, it can sometimes try to assign a port incorrectly. So it might take a few attempts to get everything to be recognized. Once it's set, you should be good.

Read More...

I love these small setups. Both yours and Gonzo's. Can you give us a rundown of the equipment? I see you have some weather devices, and maybe a box or two I'm not familiar with. I'll be setting up a "micro" observatory myself in the coming days. I'm working on drawings and yard placement at the moment.

Read More...

I was just looking at trying to implement temperature compensation as well. I've been looking closely at my data, graphing FWHM and frame quality over time, and it varies a lot with my EdgeHD 11. But once I have this data and plot it, how do I get the information into EKOS to utilize it? I don't see anything obvious for inputting the temperature focus parameters. There's a refocus if temperature changes, but that seems like a brute force method. I'm looking to have something that will adjust automatically throughout the night.

Read More...

Just what the title says. The dew heater window switch is missing from the driver interface on the INDI control panel, and should be added.

Thanks!

Read More...

Yeah, this is correct. I just brought in all my equipment as we're about to have another hurricane in our area. But I'm going to test every parameter around time, and see what comes into EKOS from the mount with each option just to confirm everything before any changes are made.

Despite using the settings I prescribed above, and having the correct time in EKOS as pulled from the mount, my meridian flip went early about 1 hour, so something is still not correct.

Of course, if I make EKOS the master time keeper, everything works as planned. It's only when I make the mount the time and location master that things go wrong. Pointing accuracy is hurt when I sync time and location to the mount, so do need to get the issue sorted out.

Read More...

knro wrote: If DST is observed, the offset from the <strong>mount</strong> should be -5. It should say -5 in INDI Control Panel.


Yes, this seemed obvious to me. But that's not what it's doing. The mount Offset is -6. That's one setting. Then there's a separate DST setting to Yes or No.

When DST is set to Yes, he mount's clock represents this correctly. But the offset in the mount is still -6.

So the internal mount clock is only for display purposes in the hand controller. And the mount information is not determined by that, but by the actual UTC time. So I have to operate the mount with incorrect settings (no DST), and the hand controller shows the wrong time, but EKOS now has the right time.

Read More...

I should have mentioned too, that I don't auto connect. So the log should show the time. Just search for UTC, and you'll find where it gets the time from the mount. I thought I quoted the relevant line in that post with the log unless that was something else.

Read More...

knro wrote:
Andrew, so 10Micron uses LX200 and it queries <strong>Local</strong> date and time, then using the offset received from the mount, it generates the UTC time. If you turn off auto connect in your equipment profile, this allows logging to be enabled before connection to the mount is established. Then connect by pressing "Connect" and then the log should show what time/offset are received from the mount itself. The log you attached doesn't show this info yet.


Interesting, I would have never figured that out. When I put all the correct information into my mount, UTC offset -6 for Central Time (Houston Texas). Currently observing DST (DST On). KStars somehow is off by 1 hour. So I have to turn DST off on the mount, then Kstars displays the correct time. So maybe Kstars is adjusting for DST itself?

Read More...

knro wrote:

sonny486 wrote: Mine turned out to be KStars had the DST rules for my geographic location incorrect, I just made a copy of my location and put -5 hrs instead of -6 that was the rule in KStars. Fixed the issue.


What's the rule that requires fixing?


What I discovered through my own trial and error is that the only things that sync from the mount to KStars is the actual UTC time (with no offset and no DST setting), and your GPS coordinates. It appears KStars then knows based on your location what offset and DST to apply to your current location and then corrects the time.

This means that if I plug in DST settings into the mount, KStars doesn't know that there is a DST set, because it thinks it's only getting the UTC time, and it offsets the time by DTC even though you've already done it in the mount now making KStars have the wrong time by one hour.

I don't know if this is driver dependent or not. But that seems to be the way the 10Micron driver works. It could be different for other mounts.

Read More...

It's pulling the location from the mount, and clearing out the location settings I manually put into KStars.

Read More...

I think I just got to the bottom of this. It is related to DST, but it doesn't make any sense.

In my original post, I had the mount running purely on UTC time with no offset for my local zone, and daylight savings time off.

EKOS should have read that across exactly and applied UTC time but looks like EKOS was somehow compensating for DST by adding an hour.

The only combination I was able to get to finally work correctly is to set UTC time on the mount to -6 (Central time zone US). Daylight Savings time off.

Now EKOS and the mount show the same time. Somehow EKOS detects whether or not DST is in effect in your local area regardless of the time the mount sends. If I set DST on in my mount, then my mount feeds EKOS with the DST time, and EKOS compensates by adding an hour thinking it is correcting for DST time.

The correct combination of all settings in the mount, produce a problem in EKOS because only the time is sent over from the mount, and not the DST status, and it looks like EKOS is applying the DST status to the time it gets from the mount.

Read More...