Hi Alessandro,

I had the same problem, and I solved it by downloading the QHY SDK for arm64 from QHY and replacing /sbin/fxload with the one in the SDK.

You may find references to this problem by searching QHYCCD USB3 linux support.

Regards,

Jordi.

Read More...

Jordi Sesé replied to the topic '64bit Astroberry' in the forum. 2 months ago

Just in case anyone is interested...

I have been able to install Raspbian 64bit (bullseye); I then added astroberry repo.
That way I was able to install PHD2 and kStars (bleeding: 3.6.0) which are in the astroberry repo.

At first, kStars crashed, but following a trick I found in a german forum in which they where discussing this installation (www.indilib.org/forum/astroberry/12390-6...rry/reply/86978.html), I removed kstars-bleeding, installed the standard kStars in raspbian, started it with a simulator profile, and then installed again kstars-bleeding - it worked!

Anyway, I'm still configuring the system but it seems to work, and without compiling a thing.

I don't know whether the packages are being built right now, the 3.6,0 64bit version I got installed corresponds to Build: 2022-08-27T18:31:54Z


Regards,

Jordi.

Read More...

I think I worked out your *strange behaviour*, Alfred. I guess the target focus position gets updated the moment we click, calculating the destinantion position adding to the current position, and not the to the end of the previous click (the ongoing movement)

In this log, every click should move 500 steps, but look what happens every time we meet Focusing outward by 500 steps

[2022-10-04T19:45:43.663 CEST INFO ][           org.kde.kstars.indi] - OnFocus :  "[INFO] Focuser is moving to position 6500 "
[2022-10-04T19:45:43.894 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  6004 State: Busy
[2022-10-04T19:45:45.460 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  6038 State: Busy
[2022-10-04T19:45:47.026 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  6168 State: Busy
[2022-10-04T19:45:48.587 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  6324 State: Busy
[2022-10-04T19:45:50.152 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  6461 State: Busy
[2022-10-04T19:45:51.718 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  6496 State: Busy
[2022-10-04T19:45:53.282 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  6500 State: Busy
[2022-10-04T19:45:53.312 CEST INFO ][           org.kde.kstars.indi] - OnFocus :  "[INFO] Focuser reached requested position. "
[2022-10-04T19:45:58.067 CEST INFO ][     org.kde.kstars.ekos.focus] - "Focusing outward by 500 steps..."
[2022-10-04T19:45:58.083 CEST INFO ][           org.kde.kstars.indi] - OnFocus :  "[INFO] Focuser is moving to position 7000 "
[2022-10-04T19:45:59.443 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  6520 State: Busy
[2022-10-04T19:46:01.005 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  6604 State: Busy
[2022-10-04T19:46:02.567 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  6760 State: Busy
[2022-10-04T19:46:03.248 CEST INFO ][     org.kde.kstars.ekos.focus] - "Focusing outward by 500 steps..."
[2022-10-04T19:46:03.263 CEST INFO ][           org.kde.kstars.indi] - OnFocus :  "[INFO] Focuser is moving to position 7260 "
[2022-10-04T19:46:04.123 CEST INFO ][     org.kde.kstars.ekos.focus] - "Focusing outward by 500 steps..."
[2022-10-04T19:46:04.138 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  6916 State: Busy
[2022-10-04T19:46:04.159 CEST INFO ][           org.kde.kstars.indi] - OnFocus :  "[INFO] Focuser is moving to position 7260 "
[2022-10-04T19:46:04.861 CEST INFO ][     org.kde.kstars.ekos.focus] - "Focusing outward by 500 steps..."
[2022-10-04T19:46:04.881 CEST INFO ][           org.kde.kstars.indi] - OnFocus :  "[INFO] Focuser is moving to position 7416 "
[2022-10-04T19:46:05.693 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  7071 State: Busy
[2022-10-04T19:46:07.254 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  7227 State: Busy
[2022-10-04T19:46:08.815 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  7372 State: Busy
[2022-10-04T19:46:10.379 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  7410 State: Busy
[2022-10-04T19:46:11.945 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  7416 State: Busy
[2022-10-04T19:46:11.975 CEST INFO ][           org.kde.kstars.indi] - OnFocus :  "[INFO] Focuser reached requested position. "

Not sure if this is a bug or a feature... anyway, it explains what you see.

Regards,

Jordi.

Read More...

Hi Alfred, welcome to the thread!

Very interesting. I also wanted to test that usleep, it's great reading that it works for you!

And about that strange behaviour... Have you enabled the debug log? All clicks should move a fixed amount of ticks/steps and go to an absolute position. Do you have a backlash value defined?

Regards from Barcelona,

Jordi.

Read More...


Yes Gene, of course. Here you have the log of that session.

File Attachment:

File Name: log_20-13-33.txt
File Size: 264 KB


Thanks for your help, and regards.

Jordi.

Read More...

Hi Gene, thanks for your suggestions.

I do not have a developer environment in the rPi (it runs from an SD card), but I can do it in the Mac. I will try to modify the driver following your advice, but it may take longer to test.

In the meantime, yesterday night I switched to the Polynomial algorithm and the autofocus process (I ran it three times) worked without timeouts. Perhaps it has to do with how the Linear algorithm works? well, anyway, it is a positive change.

I will go on with my tests and update this thread with my results. If you have any other suggestions, they will be very welcome!

Thanks for your help, and regards,

Jordi.

Read More...

Hi all,

New test tonight, and same results in the log. After every "Linear: un-doing extension. Moving back in by XX", there is a tty error.
I post here the lines, no need to attach all the log file, it's the very same.


[2022-10-01T23:40:04.814 CEST INFO ][           org.kde.kstars.indi] - RoboFocus :  "[INFO] Moving outward... "
[2022-10-01T23:40:04.841 CEST INFO ][           org.kde.kstars.indi] - RoboFocus :  "[INFO] Stopped. "
[2022-10-01T23:40:04.841 CEST DEBG ][     org.kde.kstars.ekos.focus] - Abs Focuser position changed to  10301 State: Ok
[2022-10-01T23:40:04.841 CEST DEBG ][     org.kde.kstars.ekos.focus] - "Linear: un-doing extension. Moving back in by 15"
[2022-10-01T23:40:04.841 CEST INFO ][     org.kde.kstars.ekos.focus] - "Focusing inward by 15 steps..."
[2022-10-01T23:40:04.847 CEST INFO ][           org.kde.kstars.indi] - RoboFocus :  "[INFO] Focuser is moving to position 10286 "
[2022-10-01T23:40:08.102 CEST INFO ][           org.kde.kstars.indi] - RoboFocus :  "[ERROR] TTY error detected: Timeout error "
[2022-10-01T23:40:08.107 CEST INFO ][           org.kde.kstars.indi] - RoboFocus :  "[WARNING] Bogus position: (00 00 00 00 00 00 00 00 00) - Bytes read: -1 "


And I did use another power source this time to feed the Robofocus: a reliable 12V 4A, to discard that also.

I guess next test will be to change the autofocus algorithm...

Any other idea?

Thanks for you help, and regards.

Jordi.

Read More...

Thanks for your replay Gene,

Yes, the latter log was obtained in the Mac, where I clicked as fast as I could both manual focus buttons in order to reproduce the same response from the driver. It is not the same operation, but the resulting response was the same.

The Astroberry based kstars/ekos enabled/disabled debug without my intervention and seemed a bit more obscure, that's why I cropped it in the first message... I'm attaching it now anyway, I hope it shows the issue in a better way.

File Attachment:

File Name: log_19-16-36.txt
File Size: 382 KB


The lines reading "RoboFocus" is disconnected it's me, manually disconnecting/reconnecting the driver in the indi interface for the process to go on.

Anyway, reviewing the logs again, now I see that every time there is a timeout, it is preceeded by a line reading Linear: un-doing extension. Moving back in by... I guess this happens every time backlash correction is applied.
Perhaps those orders are sent too fast for this focuser? Any other ideas?

As per the power source, it is a 12V 10A power supply. It feeds most of the equipment. I think I will power the focuser from a separate source next time to assure it has nothing to do with this issue.

Thanks for your help, and regards,

Jordi.

Read More...

I have done the same test in my Mac, with the most recent 3.6.1 beta (Build: 2022-09-30T18:04:42Z), another serial/USB cable, and it behaves the same way.

When It gets the timeout, I wait some seconds, click again on a manual focus button and starts working again. If I don't click, it goes on with the timeout/bogus errors

File Attachment:

File Name: log_22-42-00.txt
File Size: 90 KB


Read More...

Hi All,

I'm running current kStars/eKos 3.6.0 under Astroberry. Recently I added a Robofocus to my setup. I seems to work fine in manual mode but I have problems with the autofocus process. I have other focusers (diy OnStep/OnFocus) autofocusing fine, I only have issues with the RoboFocus.

I have noticed that the RoboFocus indi driver produces errors (tty timeout / bogus position) when autofocusing. I usually manually disconnect/connect the indi driver for the process to continue.

Trying to know what happens in order to tell it more clearly, I have managed to reproduce it when moving the focuser manually: It works fine in normal use, but this issue happens when I change focus directions very fast. In the log, it always reads State: Busy at the end of the position notice, just before the timeouts occur:

INFO ][ org.kde.kstars.ekos.focus] - "Focusing outward by 3 steps..."
[2022-09-30T19:20:35.358 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[INFO] Moving outward... "
[2022-09-30T19:20:35.752 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[INFO] Stopped. "
[2022-09-30T19:20:35.753 CEST DEBG ][ org.kde.kstars.ekos.focus] - Abs Focuser position changed to 10175 State: Busy
[2022-09-30T19:20:35.758 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[INFO] Focuser is moving to position 10181 "
[2022-09-30T19:20:39.007 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[ERROR] TTY error detected: Timeout error "
[2022-09-30T19:20:39.012 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[WARNING] Bogus position: (00 00 00 00 00 00 00 00 00) - Bytes read: -1 "
[2022-09-30T19:20:46.014 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[ERROR] TTY error detected: Timeout error "
[2022-09-30T19:20:46.020 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[WARNING] Bogus position: (00 00 00 00 00 00 00 00 00) - Bytes read: -1



If I do nothing, the system keeps outputting this error. In manual mode, if I press again any button for a manual movement, everything works again.

When running autofocus, it keeps waiting until I disconnect/connect manually (then the autofocus process tries to continue). In that case, the log does not tell that 'Busy' state, but the result is exactly the same happening in manual mode:

org.kde.kstars.ekos.focus] - "Focusing outward by 31 steps..."
[2022-09-28T22:28:10.149 CEST DEBG ][ org.kde.kstars.indi] - RoboFocus : "[DEBUG] Moving Absolute Position: 10209 "
[2022-09-28T22:28:10.149 CEST DEBG ][ org.kde.kstars.indi] - RoboFocus : "[DEBUG] CMD (0X46 0X47 0X30 0X31 0X30 0X32 0X30 0X39 0XB9) "
[2022-09-28T22:28:10.151 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[INFO] Focuser is moving to position 10209 "
[2022-09-28T22:28:10.394 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[INFO] Moving outward... "
[2022-09-28T22:28:10.515 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[INFO] Stopped. "
[2022-09-28T22:28:10.515 CEST DEBG ][ org.kde.kstars.ekos.focus] - Abs Focuser position changed to 10209 State: Ok
[2022-09-28T22:28:10.516 CEST DEBG ][ org.kde.kstars.ekos.focus] - "Linear: un-doing extension. Moving back in by 15"
[2022-09-28T22:28:10.517 CEST INFO ][ org.kde.kstars.ekos.focus] - "Focusing inward by 15 steps..."
[2022-09-28T22:28:10.520 CEST DEBG ][ org.kde.kstars.indi] - RoboFocus : "[DEBUG] Moving Absolute Position: 10194 "
[2022-09-28T22:28:10.520 CEST DEBG ][ org.kde.kstars.indi] - RoboFocus : "[DEBUG] CMD (0X46 0X47 0X30 0X31 0X30 0X31 0X39 0X34 0XBC) "
[2022-09-28T22:28:10.522 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[INFO] Focuser is moving to position 10194 "
[2022-09-28T22:28:13.774 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[ERROR] TTY error detected: Timeout error "
[2022-09-28T22:28:13.778 CEST INFO ][ org.kde.kstars.indi] - RoboFocus : "[WARNING] Bogus position: (00 00 00 00 00 00 00 00 00) - Bytes read: -1 "

I have tried changing the serial<->USB cable, and it makes no difference.

Perhaps this device needs a small extra pause after sending every command?. I have not found a place to make such an adjustment in the driver interface. Setting higher values in the polling period (4s right now) or settle times (2s) made no difference.

Is there anything else I can try in order to solve this issue?

Thanks for your help.

Regards from Barcelona

Read More...

Jordi Sesé replied to the topic 'Ekos Optical Trains' in the forum. 2 months ago

I am testing latest OSX beta (Build: 2022-09-17T18:07:01Z). It seems that it does not like duplicated drivers...

I wanted to check dual camera setup with simulators (if not simultaneous, at least alternative). I created a driver alias of the CCD Simulator driver and named it 'CCD Simulator_2'.

I then added it in a profile as Aux1 (since there's no other option right now) and CCD Simulator as main CCD camera. The result was that the Optical Trains interface stopped working. It did not appear when connecting drivers, and when called, it was blank, and it closed the app when clicking the '+' button to add a train.

This also happened when modifying an existing profile with just one camera when adding the alias as Aux, not just with new profiles.

I guess it is easy to reproduce. If you need any more info, just let me know.

Thanks for your time, and regards from Barcelona.

Read More...

I downloaded a new update today on the rPi, and now OnStep driver shows the 'Rotator' tab (thanks again, James).

PHD2 (2.6.9dev5) keeps crashing when connecting to the mount, but it does the very same when connecting to the Telescope Simulator driver, so it's not driver related. Hope to solve it soon to be able to test the whole thing...

Regards,

Jordi.

Read More...