Tony W created a new topic ' Pentax Support EKOS/Kstars' in the forum. 2 months ago

Hello
I'm aware that there are some users of Exos/kStars that aim to use Pentax cameras in their system. I have done some testing using a K20D, K30 and K3ii with mixed results. By far, the most success (with camera control and Ekos) I have had is with the K20D, partial success with the K3ii (very short exposures only) and none really with the K30. I have also scanned the web for other software solutions that work with Pentax gear and see that its a similar picture there also. Now I truly think the Kstars workflow is good and I'm keen to push the Pentax envelope and see how the functionality available can be improved. I am happy to act as a test bed and may even be pursuaded to brush up on my C skills and have a go at improving the drivers. Please let me know how we can proceed? Many thanks for your time, Tony.

Read More...

Tony W replied to the topic 'Pentax K3ii with Kstars/Ekos' in the forum. 3 months ago

Ok latest news. Using M mode with the Native drivers, 1 or 2 second exposures, I can take single shot images in FITS format (with the ISO I choose) or Native (saved as .raw with no viewer). Sequences can also be taken and the FITS files drop in the required directory.

Anything longer just hangs again. I did add a 2 sec delay and I thought I could do a 10 sec exposure, however, I could only get this result once and unable to repeat.

So, it seems that the process flows appear to work, and I guess some code tweaks may yield more exposure possibilities, unless anyone has other parameter tweaks to suggest?

Read More...

Tony W replied to the topic 'Pentax K3ii with Kstars/Ekos' in the forum. 3 months ago

So I played some more and set the remote control option in the camera menus to active. I also set the jpeg file size (but assume this will have no effect on the raw image). The camera took a 1 sec exposure as instructed by kstars and then stalled. Checking the log the capture completed bu the software was waiting for the download (see below).



Read More...

Tony W replied to the topic 'Pentax K3ii with Kstars/Ekos' in the forum. 3 months ago

Now that's interesting and useful to know as I'm considering the Stellarmate pro to speed things up. Just wanted to be certain that I can use it with my pentax cameras/lenses.

Read More...

Tony W replied to the topic 'Pentax K3ii with Kstars/Ekos' in the forum. 3 months ago

PTP mode had no real functionality in my tests, fyi

Read More...

Tony W replied to the topic 'Pentax K3ii with Kstars/Ekos' in the forum. 3 months ago

I wonder if that may be it. I will lower the raw file size and see if that makes a difference. As for Legacy, I have a testing protocol used for the K20D and K30 that cycles thru Native, Legacy and Gphoto and tries out functions. I recall that with Legacy, I got two Pentax K3ii tabs and no shutter action. Curiously, for both Legacy and Gphoto, the shutter release port field was blank with its corresponding lamp (green, yellow, red, etc) was unlit. I wonder if there is a /dev/tty? expert out there?

Read More...

Tony W replied to the topic 'Pentax K3ii with Kstars/Ekos' in the forum. 3 months ago

Had thought so too, yet other much older posts point to astrotracer being on as a way to step forward. I wasn't able to open and close the shutter when astrotracer was turned off. I presume, when things settle into a working order, I can turn tracking off on the mount when capturing. I'm more curious about the loop the log shows (saved buffer incrementing until 870..?

Read More...

Tony W created a new topic ' Pentax K3ii with Kstars/Ekos' in the forum. 3 months ago

Hello
I've just started testing Kstars 3.6.8 on a macbook air, Pi4 setup. You may have seen my tinkering with the K20D on a similar setup. I made sure the macbook version of kstars matched the version on the Pi4. I'm using the native pentax driver. Astrotracer is on and buld settings are capture and hold.
Running up the connection I connect and then get 2 warnings about ISO and exposure compensation. Then a red error (see below).



At this stage I'm able to update ISO and switch between native and fits. If I set a 1 sec or 10 sec exposure, the shutter opens for the required time, closes and then I wait...for eternity it seems. To close, I abort the capture (this hangs the camera needing a battery reset). for log file trace see below. Any ideas what to do next?



Read More...

Tony W replied to the topic 'Pentax DSLR testing updates' in the forum. 7 months ago

Ok some updates after a bit of an absence. By setting the Presets setting to BULB, on the Indi Main Control tab in Kstars, I am able to take 60s, 120s or 300s exposures in an automated sequence. Indi will thro a failed to expose error, then go thru the motions of taking another image (but not actually doing so) and the exposure will complete. The downside is that the total time for the image capture is effectively double your requested exposure time. But hey, long exposures are now possible!



Read More...

Ok some updates after a bit of an absence. By setting the Presets setting to BULB, on the Indi Main Control tab in Kstars, I am able to take 60s, 120s or 300s exposures in an automated sequence. Indi will thro a failed to expose error, then go thru the motions of taking another image (but not actually doing so) and the exposure will complete. The downside is that the total time for the image capture is effectively double your requested exposure time. But hey, long exposures are now possible!



Read More...

Tony W created a new topic ' Pentax DSLR testing updates' in the forum. 12 months ago

Hello Everyone
I've been using Kstars and Ekos on a Raspberry Pi 4, Mac for a while now and wanted to share results using a K20D Pentax camera. I use an Alt-Az mount from Skywatcher.

I started having viewed the youtube video on using a DSLR as a telescope by a popular content creator and got hold of the bits to get going.

I wasn't able to get far with Stellarmate, with various issues getting in my way. However, I was able to move forward by using the Kstars, Ekos software that is more verbose when tracking down issues via logs etc. Stellarmate is just a front end that sits above I believe.

I used a setup where I connect to the Raspberry Pi via VNC and start a server (details on how can be found here www.macobservatory.com/blog/2020/6/4/rem...using-a-raspberry-pi - just love the internet! ). I can the use Kstars and Ekos on my mac to find, track and capture sky objects.

The software can be a bit flaky but by following a process when setting up and powering on, I can get to my first plate solve in about 5 minutes and sessions will generally be robust after that.

I was surprised and the quality of images I can capture and stack in Siril ( that seems to get around the field rotation issue with Alt Az mounts ) and have now stared to push a bit harder with some more distant objects.

So I have a K20D that I picked up cheaply with some lenses. I also have a K30 that I have attempted to use.

I have had most success with the K20D as the primary camera. I use the legacy Pentax driver and am able to set ISO, exposure time (up to but no higher than 14 secs), plate solve quickly and make use of the neat dynamic directory creation for sky objects (a set of directories that store the lights images by the object name) so i can revisit the same object and add more data over time. As the mount is a GOTO design, I can come back, plate solve and continue to image, one night to the next in both FITS format and RAW (native).

I've tried to improve the exposure time but 14 seconds seems to be the limit before I get errors. I have no real success using the K30 with the native driver (M mode only) or legacy.

Things I want to try out next:

1) The autofocus dialog box for the K20D is available when I plug in an auto focus lens so I will try to see how I can get that to work.
2) I may change the mount to the dual camera version so I can try to use the K30 too. I will have to activate the K30 via a separate remote with the K20D driving GOTO and primary imaging via Kstars. I'm curious to see if I can leverage Astrotracer (with the GPS unit) to take longer exposures whilst on the mount. Not sure if it will work if Astrotracer uses a fixed rotation algo rather than sensing rotation via its inbuilt accelerometers and adjusting the sensor accordingly.
3) Upgrade to a newer Pentax such as the K3 ii or iii and hope that one of the drivers available can work as well as the K20D or better.

If anyone has an idea how I can improve on the K20D's 14secs exposure time I'd be grateful. The software correctly time the snap but the issue appears to be on the download cycle.

Kind regards. Tony




I

Read More...

Hello Everyone
I've recently had some success pairing a K20D Pentax DSLR with the Alt-Az GTI mount from Skywatcher. Hit a dead end with the stellarmate app but then diverted to use Kstars/Ekos on the Pi controlled by a Kstars instance on my mac. This allows me to click on a target, call up a GOTO and plate solve/track on the mac.

I'm able to set ISO, exposure time upto but no more than 14s, plate solve and make use of the named target directory structures that allow me to save raw images for a specific target day after day. The job schedule tool works too.

I stack with Siril and that seems to get around the field rotation issue.

Does anyone have an idea why 14 seconds seems to be a limit for an exposure? The camera opens and closes the shutter on command, the trouble seems to be on the download phase.

Kind regards, Tony

Read More...