×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

ZWO EAF: Reverse Motion not working

3 months 4 weeks ago
DerPit
Platinum Boarder
Platinum Boarder
Posts: 457
Karma: 1
More
Topic Author
ZWO EAF: Reverse Motion not working #52035
I mounted my EAF on a new telescope. For it, the normal motion 'Focus in' will move the camera outwards. So I selected 'Reverse Motion -> Enable'. No error, and 'Enable' gets highlighted. But the camera continues to move outwards with 'Focus in'. I made sure 'Enable' is highlighted, saved the configuration, dis- and re-connected to the unit, which set Reverse Motion back to 'Disabled'.

Seems something's broken there?

This is latest git (yesterday) for both INDI and KStars.

openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+EAF+ASI290 mini

Please Log in or Create an account to join the conversation.

3 months 4 weeks ago
jpaana
Gold Boarder
Gold Boarder
Posts: 262
Karma: 5
More
ZWO EAF: Reverse Motion not working #52063
I have INDI compiled from today too (and usually compile the sources daily if there are changes) and have had the reverse motion option enabled since I got the focuser last autumn without issues. So it should work fine. Have you updated the firmware? I've updated mine to 3.1.9, but didn't have issues with 3.1.7 or 3.1.6 either. Unfortunately the update requires a Windows machine, but is simple to do otherwise.

Remote observatory running Ubuntu 20.04 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
The following user(s) said Thank You DerPit

Please Log in or Create an account to join the conversation.

3 months 4 weeks ago
DerPit
Platinum Boarder
Platinum Boarder
Posts: 457
Karma: 1
More
Topic Author
ZWO EAF: Reverse Motion not working #52065
Uuh, too bad. Windows is something I don't have. I might try it with wine. Serial/USB stuff (like the mount) works that way, but I/m not sure about HID devices.
So the current drivers only work with new firmware? I'm quite certain that the reverse had worked last year with the FW I have (which is 3.1.3) :(
I'll see how I can update it. So thanks for the hint!

openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+EAF+ASI290 mini

Please Log in or Create an account to join the conversation.

3 months 4 weeks ago
DerPit
Platinum Boarder
Platinum Boarder
Posts: 457
Karma: 1
More
Topic Author
ZWO EAF: Reverse Motion not working #52066
Hmm, as I was afraid, wine seems not to work. It just cannot see the device :(

openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+EAF+ASI290 mini

Please Log in or Create an account to join the conversation.

3 months 4 weeks ago
suvowner
Expert Boarder
Expert Boarder
Posts: 86
More
ZWO EAF: Reverse Motion not working #52068
there are issues with Mac OS seeing that device. it should work with the rpi4 though.

Please Log in or Create an account to join the conversation.

3 months 4 weeks ago
DerPit
Platinum Boarder
Platinum Boarder
Posts: 457
Karma: 1
More
Topic Author
ZWO EAF: Reverse Motion not working #52072

suvowner wrote: there are issues with Mac OS seeing that device. it should work with the rpi4 though.


Uhm, somewhat puzzled....:blink:
I neither use Mac nor Pi, and the problem was not using the EAF, but upgrading its firmware.....

openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+EAF+ASI290 mini

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago
mdlearnest
Fresh Boarder
Fresh Boarder
Posts: 5
More
ZWO EAF: Reverse Motion not working #52421
My reverse button quit working out of the blue! I've sense updated the firmware from ZWO, no change. It is the indi driver because when i connect to the EAF with the ascom driver, all works well. It's only when connecting with the indi driver does the reverse not work. Any help would be greatly appreciated.

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago
knro
Administrator
Administrator
Posts: 8213
Karma: 51
ZWO EAF: Reverse Motion not working #52432
Please update to the latest INDI nightly/stable and it should be resolved.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago
mdlearnest
Fresh Boarder
Fresh Boarder
Posts: 5
More
ZWO EAF: Reverse Motion not working #52437
yes! its now working properly!!! thanks!

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago
DerPit
Platinum Boarder
Platinum Boarder
Posts: 457
Karma: 1
More
Topic Author
ZWO EAF: Reverse Motion not working #52441
Yes, also confirmed here. It works (again - I had gotten unsure if I really had it seen working before....), despite my old firmware.

openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+EAF+ASI290 mini

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago
mdlearnest
Fresh Boarder
Fresh Boarder
Posts: 5
More
ZWO EAF: Reverse Motion not working #52455
nope! spoke too soon. it worked initially, but after a reboot its no longer working. i even did a complete re-image with rasp. lite and still the reverse buttons have the wrong direction.

Please Log in or Create an account to join the conversation.

3 months 3 weeks ago
DerPit
Platinum Boarder
Platinum Boarder
Posts: 457
Karma: 1
More
Topic Author
ZWO EAF: Reverse Motion not working #52501
Not sure what you mean with 'reverse buttons have the wrong direction'. The important thing is it reverses direction of motion when you enable it. And that does work here again with the current (self-compiled) git version....

openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI1600+EFW+EAF+ASI290 mini

Please Log in or Create an account to join the conversation.

Time to create page: 0.971 seconds