×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Why is the UTC time in KStars/Ekos different from my mount?

The rule is correct for McAllen. It's -5 now, and in the database it's -6 (RAW without DST correction). So mount should report -5 which is sent to Ekos. Ekos checks DST is on and subtracts 1, so we're back to -6 which is set as the RAW uncorrected offset (TZ0).

Andrew, so 10Micron uses LX200 and it queries <strong>Local</strong> date and time, then using the offset received from the mount, it generates the UTC time. If you turn off auto connect in your equipment profile, this allows logging to be enabled before connection to the mount is established. Then connect by pressing "Connect" and then the log should show what time/offset are received from the mount itself. The log you attached doesn't show this info yet.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
Last edit: 2 years 1 month ago by Jasem Mutlaq.
2 years 1 month ago #61169

Please Log in or Create an account to join the conversation.

  • Posts: 165
  • Thank you received: 23
Ok, I will check my mount, and make sure the DST is set to off.

I recently did a firmware update to my mount, maybe it set it to on.
Thanks for your hard work on all this, (I see you guys are doing lots of changes on invent.kde.org, lots of great stuff happening!)
2 years 1 month ago #61170

Please Log in or Create an account to join the conversation.

  • Posts: 527
  • Thank you received: 138

Interesting, I would have never figured that out. When I put all the correct information into my mount, UTC offset -6 for Central Time (Houston Texas). Currently observing DST (DST On). KStars somehow is off by 1 hour. So I have to turn DST off on the mount, then Kstars displays the correct time. So maybe Kstars is adjusting for DST itself?
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
2 years 1 month ago #61171

Please Log in or Create an account to join the conversation.

  • Posts: 527
  • Thank you received: 138
I should have mentioned too, that I don't auto connect. So the log should show the time. Just search for UTC, and you'll find where it gets the time from the mount. I thought I quoted the relevant line in that post with the log unless that was something else.
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
2 years 1 month ago #61172

Please Log in or Create an account to join the conversation.

If DST is observed, the offset from the mount should be -5. It should say -5 in INDI Control Panel.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 1 month ago #61173

Please Log in or Create an account to join the conversation.

  • Posts: 527
  • Thank you received: 138

Yes, this seemed obvious to me. But that's not what it's doing. The mount Offset is -6. That's one setting. Then there's a separate DST setting to Yes or No.

When DST is set to Yes, he mount's clock represents this correctly. But the offset in the mount is still -6.

So the internal mount clock is only for display purposes in the hand controller. And the mount information is not determined by that, but by the actual UTC time (it says this in the manual). So I have to operate the mount with incorrect settings (no DST), and the hand controller shows the wrong time, but EKOS now has the right time.
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
Last edit: 2 years 1 month ago by Andrew Burwell.
2 years 1 month ago #61174

Please Log in or Create an account to join the conversation.

So the mount would send -6 regardless on whether or not the DST is ON/OFF in the hand controller?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
2 years 1 month ago #61195

Please Log in or Create an account to join the conversation.

  • Posts: 527
  • Thank you received: 138
Yeah, this is correct. I just brought in all my equipment as we're about to have another hurricane in our area. But I'm going to test every parameter around time, and see what comes into EKOS from the mount with each option just to confirm everything before any changes are made.

Despite using the settings I prescribed above, and having the correct time in EKOS as pulled from the mount, my meridian flip went early about 1 hour, so something is still not correct.

Of course, if I make EKOS the master time keeper, everything works as planned. It's only when I make the mount the time and location master that things go wrong. Pointing accuracy is hurt when I sync time and location to the mount, so do need to get the issue sorted out.
-Andrew
––––––––––
Mac Observatory - All about using the Mac for Astrophotography: www.macobservatory.com
Astrobin: www.astrobin.com/users/Lead_Weight/
2 years 1 month ago #61199

Please Log in or Create an account to join the conversation.

  • Posts: 2151
  • Thank you received: 205
same issue here, I've tried DST off / on at the hand controller, it makes no difference.

Mount time: set to what the current GMT+1 is (as current location is London)
Mount DST: off
MOUNT UTC: +060

Ekos:
Mount Updates Kstars
Time sync ticked

and I get in the bottom left corner the time in UTC and not UTC+1
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO533MC / QHY5L-II-M (OAG)
2 years 1 month ago #61201

Please Log in or Create an account to join the conversation.

  • Posts: 83
  • Thank you received: 35
Hi all,
I'm not sure if this issue still exists. I've not had it myself. I have no MGPBOX or GPS and use the 'kstars updates time' setting.
If ppl still have this issue then next to Jasem's enable debug log before you connect post earlier in this thread is a good place to start, and maybe this helps for those that are not afraid to telnet to an API :
The 10micron API can be reached on port 3490 as follows :
telnet <your mount IP address or DNS name> 3490
here you can give commands to the mount, like 'what is todays date' and I've added my mounts' responses so you have an idea what format expect
#:GC#
2020-12-24#
or what is your timezone offset ?
#:GG#
-01:00:00.0#
or what time do you think it is now ?
#:GL#
00:21:22.48#
Maybe this helps anyone in finding any discrepancies.
-- Hans
1 year 11 months ago #64913

Please Log in or Create an account to join the conversation.

  • Posts: 124
  • Thank you received: 10
I know this is an old thread but wondering if this was ever resolved. Previously I had my 10micron updating kstars and it all seemed to work. After updating kstars to 3.5.9 on ubuntu linux I now seem to have kstars time offset by 1 hour from correct local time and meridian flip is messing up. It seems OK if I set kstars update mount. I have also seen it suggested to not have mount and kstars trying to sync time and let GPS set mount independently of kstars. What is the currently understood best way to do this?
Borg 107FL on RST-135 + QHY268C, Astro-Tech AT130EDT on GM1000HPS + QHY600PH Chroma LRGBHSO; IR Guiding WO Uniguide 50 & QHY5-III-462C ASUS PN51 and Mele Quieter 3 ubuntu, kstars/ekos, & firecapture; Pegasus PPBA; WO Redcat, Skyguider Pro RT90C, Canon 7DmkII, rPi4/stellarmate
5 months 3 weeks ago #83360

Please Log in or Create an account to join the conversation.

  • Posts: 319
  • Thank you received: 24
The way I manage this is by setting the Linux box time upfront (I'm using RTC) and making sure it is updated, then I run KStars and it is set up to allow KStars to control the time and location of everything else (e.g. the mount)
Clear Skies!
Mohamed

Permanent
C9.25 f/10, HEQ5, MyFocuserPro2, OAG, ASI174MC guide, ASI533MC Pro

Portable
WO Z61, iOptron SmartEQ Pro+, MyFocuserPro2, OAG, ASI120MM guide, ASI183MM Pro, EFW
5 months 3 weeks ago #83362

Please Log in or Create an account to join the conversation.

Time to create page: 0.494 seconds