×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

iOptron drivers differences

  • Posts: 2046
  • Thank you received: 193
I would like to know the differences between the following two drivers please.
And which one is actually the best choice for my CEM25p?

driver 1: INDI iEQ v1.5
indi_ieq_telescope


driver 2: CEM120 v1.1
indi_ioptronv3_telescope
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO183MM / QHY5L-II-M (OAG) / ZWO mini FW
The following user(s) said Thank You: Wouter van Reeven
8 months 3 weeks ago #60921

Please Log in or Create an account to join the conversation.

  • Posts: 391
  • Thank you received: 49

Replied by Patrick on topic iOptron drivers differences

There is a Legacy driver that looks to be compatible with many iOptron mounts. This is the one I use because the firmware of my CEM60 is not up to date. So I can't use the CEM60 specific driver.
I guess that at least you can use it
8 months 3 weeks ago #60950

Please Log in or Create an account to join the conversation.

  • Posts: 2046
  • Thank you received: 193
ok thanks, if I use the indi_ioptronv3_telescope driver, not much is working with my CEM25p and it has the latest firmware.
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO183MM / QHY5L-II-M (OAG) / ZWO mini FW
8 months 3 weeks ago #60953

Please Log in or Create an account to join the conversation.

  • Posts: 2046
  • Thank you received: 193
I think I now understand why it's the iEQ driver being used, follow up from my post here


Kstars 3.4.3 on Osx
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO183MM / QHY5L-II-M (OAG) / ZWO mini FW
8 months 3 weeks ago #60957
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 732
  • Thank you received: 94
As the driver name indi_ioptronv3_telescope suggests, this is only for mounts that support version 3 of the serial communication protocol. To my knowledge, those are at the moment only the CEM120 and the new CEM70. The other CEMs do use version 2.5 of the protocol, and therefore don't work with the v3 driver.
So I think the driver page needs some documentation update?

For the 'smaller' ioptrons there's the old version of the driver, indi_ieqlegacy_telescope, and the new, refactored indi_ieq_telescope. I have not used the legacy one on a while, but it used to work with my CEM60EC (but doesn't support all features IIRC).
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
The following user(s) said Thank You: Gonzothegreat
8 months 3 weeks ago #60973

Please Log in or Create an account to join the conversation.

  • Posts: 2046
  • Thank you received: 193
makes sense, thanks.
The documentation is not accurate, hence the confusion as to which driver to use.
Kstars Mac osx
Odroid C4 / WO Redcat51 / CEM25p / ZWO183MM / QHY5L-II-M (OAG) / ZWO mini FW
8 months 3 weeks ago #60995

Please Log in or Create an account to join the conversation.

  • Posts: 60
  • Thank you received: 7
8 months 3 weeks ago #61007

Please Log in or Create an account to join the conversation.

Time to create page: 0.551 seconds