×

INDI Library v1.9.0 Released (23 Apr 2021)

Major INDI Library release v1.9.0 bring significant internal changes championed by @pawel-soja to modernize core INDI Library drivers and clients. New drivers for DeepSkyDad Flat Panel & Pegasus devices plus further improvements to PCM8 drivers.

QHY5 - [ERROR] GetQHYCCDSingleFrame error (-1)

There is an updated libqhy in INDI Nightly repo that should fix the QHY/SSAG issue. Can you please update and test?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 8 months ago #44121

Please Log in or Create an account to join the conversation.

  • Posts: 12
  • Thank you received: 0
SSAG now capturing and looping images on the Pi3 and Pi4.

Thank you very much.

Tim
Last edit: 1 year 8 months ago by Tim Roske. Reason: Update to show results of test on RPi 4
1 year 8 months ago #44125

Please Log in or Create an account to join the conversation.

  • Posts: 9
  • Thank you received: 1
I just updated both my StellarMateOS_1.4.4 Pi3 and Pi4 systems. Can confirm that the QHY5LII-C, QHY5PII-C, QHY PoleMaster, and QHY168C are all working perfectly. Thanks
1 year 8 months ago #44149

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 2
Hi all,

I have just rebuilt my OdroidXU4 and this new version of the QHY driver works wonderfully well.

Thank you for sorting this issue.

Chris
KStars/Ekos running on OdroidXU4 Ubuntu Mate on the Mount and RDP from laptop for remote access
Telescopes: Skywatcher ED80 & Altair Astro RC6
Mount: Skywatcher HEQ5
CCD: Atik 414EX
Guider: QHY5 on Skywatcher ST80
1 year 8 months ago #44291

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
I can also confirm the latest driver works without issues with the QHYCDD 5L-II-M. Many thanks!
EQ6 - WO80mm - C8 - Atik 383L - Atik EFW2 - QHYCCD 5Lii-m - Laptop with UB18.04
1 year 8 months ago #44371

Please Log in or Create an account to join the conversation.

  • Posts: 4
  • Thank you received: 0
Hi,

I have a similar problem with my QHYIMG-0H camera, it connects successfully but fails when I try to capture a frame:
"[ERROR] GetQHYCCDSingleFrame error (-1) "

These are my first tests with Indi, so I am a bit "lost" and would need some help...

I am using the last stable release of Indi, installed yesterday following the instructions here:
indilib.org/download/raspberry-pi.html

I tried with a powered usb hub, but without differences.
I tried also with Indi installed in Ubuntu, on an other PC, same problem...

I would exclude a problem with the camera, it works well with PHD2 on Windows 7.

I add some logs, I hope they could be useful.
Thanks in advance !
1 year 5 months ago #47115
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 385
  • Thank you received: 13
Hello,

Looks like I am in the same boat as you. Both my PoleMaster and QHY5LII-C are throwing the [ERROR] GetQHYCCDSingleFrame error (-1) whenever EKOS requests a image to be taken. I can see the image being downloaded in QHY logs but the driver cancels the load.
Last edit: 1 year 5 months ago by John Robison.
1 year 5 months ago #47355

Please Log in or Create an account to join the conversation.

  • Posts: 9
  • Thank you received: 1
HI, just reloaded my system with the latest indi drivers and both my QHY5LII-C, and PoleMaster are functioning correctly.
1 year 5 months ago #47426

Please Log in or Create an account to join the conversation.

  • Posts: 385
  • Thank you received: 13
Hello,

Thank you for the good report. Here were my steps yesterday. I used Synaptic to see what QHY drivers and applications were installed. Then I removed any and all. After completion, I reinstalled indi-QHY. I will validate today what the state of both devices are in. Would you share any additional steps you took?
1 year 5 months ago #47434

Please Log in or Create an account to join the conversation.

  • Posts: 385
  • Thank you received: 13
Hello,

On a whim, I decided to check SYSLOG for any errors while testing my QHY devices with Polar Alignment and EKOS. I found the smoking gun. My error is in indi_qhy_ccd. The OS says using a USB before claiming it is the reason for the halt. I thought it strange for the QHY logs to yield an error when nothing previous to error indicated the need for an alert. Yes. The OS can stop KSTARS from operating.

Dec 30 09:00:43 astroberry kernel: [ 7592.169498] usb 1-1.2.4.1: usbfs: procesis 4686 (indi_qhy_ccd) did not claim interface 0 before use

Here is a link to the possible fix.

stackoverflow.com/questions/11088691/err...-claimed-from-libusb
1 year 5 months ago #47447

Please Log in or Create an account to join the conversation.

  • Posts: 385
  • Thank you received: 13
Hello,

This was a painful exercise. In EKOS profiles, Select Devices include 4 Auxiliary devices. In my decisions, I considered the three CCD devices as three separate uses. The ZWO for CCD, the PoleMaster for Polar Alignment, and the QHY5LII-C for guiding. Let me see... CCD and GUIDER are for ZWO and PoleMaster. The QHY5LII-C is Auxiliary 4.

Wrong! Just use INDI_QHY_CCD for Guiding and be done.

Setting up indi_QHY_CCD in two slots causes INDI to setup two instances of INDI_QHY_CCD. Having two instances of any driver causes multiple issues of communication. The error says that something is preventing the INDI_QHY_CCD driver from collecting the image. The Kernel is one such devices. The Kernel will say.

kernel: [28071.416886] usb 1-1.2.4.1: usbfs: process 10108 (indi_qhy_ccd) did not claim interface 0 before use

This stops that image process in its tracks. This closes the case for me.

PoleMaster and QHY5LII-C co-habitat under one instance of INDI_QHY_CCD. INDI_QHY_CCD resides in GUIDER or Auxiliary 4 but not both.
1 year 5 months ago #47462

Please Log in or Create an account to join the conversation.

  • Posts: 1115
  • Thank you received: 195
Makes sense. And reminds me of a similar case not long ago.
www.indilib.org/forum/ekos/6014-polar-al...-progress.html#45983

Perhaps a warning should popup whenever a profile is saved with duplicate drivers just to alert users of possible conflicts, without prohibiting it outright.
INDI/KStars on Raspberry Pi 4, 4gb
Raspbian Buster with AstroPi3 script configuration
Skywatcher HEQ5 Pro Mount
Canon 600D Camera
Orion SSAG/ASI120mm @280mm Guide Scope
PHD2
Waveshare Stepper Motor Board - DIY Focuser
Adafruit GPS Module
Generic Bluetooth Joystick.
Startech 7 port powered USB Hub.
1 year 5 months ago #47466

Please Log in or Create an account to join the conversation.

Time to create page: 1.214 seconds