×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

ASTAP astrometry integration

3 weeks 5 days ago
knro
Administrator
Administrator
Posts: 7355
Karma: 51
Topic Author
ASTAP astrometry integration #44951
So I just landed this in GIT master. Please test! Not only ASTAP, but also whether ASTAP integrated caused any regressions in how astromtry.net works.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You pug916

Please Log in or Create an account to join the conversation.

3 weeks 3 days ago
mlarsson
Platinum Boarder
Platinum Boarder
Posts: 322
Karma: 1
More
ASTAP astrometry integration #45017
Hi!

Great! Does that mean that it should be available in nightly? (couldn't find it yesterday when updating)

Magnus


C8, Losmandy G11, Canon 1000D astromodified.

Please Log in or Create an account to join the conversation.

3 weeks 3 days ago
jpaana
Gold Boarder
Gold Boarder
Posts: 214
Karma: 5
More
ASTAP astrometry integration #45023
I get the following error from ASTAP and it doesn't seem to load the image even if I press ok. I also compiled the source with distro (Ubuntu 19.10 x64) compiler just for testing and got the same error.

Remote observatory running Ubuntu 19.10 x64 with ScopeDome 2M, Skywatcher EQ8 and HEQ5, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, USB_Focus V3, Gemini SnapCap, USB_DewPoint, KomaHub
Attachments:

Please Log in or Create an account to join the conversation.

3 weeks 3 days ago
stash
Gold Boarder
Gold Boarder
Posts: 306
Karma: 4
More
ASTAP astrometry integration #45024
I can confirm that I get the same error under Ubuntu - as already stated in the thread on ASTAP live Stacking . :-)

RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????

Please Log in or Create an account to join the conversation.

3 weeks 1 day ago 3 weeks 1 day ago by han.k.
han.k
Gold Boarder
Gold Boarder
Posts: 169
Karma: 5
More
ASTAP astrometry integration #45064
Fixed in ASTAP version 0.9.288. All Linux versions are now updated (The error was caused by added a memo scroll in the last versions which caused this error in the command line only. :( )
The following user(s) said Thank You pug916

Please Log in or Create an account to join the conversation.

3 weeks 1 day ago
han.k
Gold Boarder
Gold Boarder
Posts: 169
Karma: 5
More
ASTAP astrometry integration #45065

jpaana wrote: I get the following error from ASTAP and it doesn't seem to load the image even if I press ok. I also compiled the source with distro (Ubuntu 19.10 x64) compiler just for testing and got the same error.


jpaana,

Just had a look to your settings. The solution goes to /tmp/solution. The solution will be small .wcs and .ini files. Both could be read for the solution. The parameter -update will copy the source image with the solution added to header to the same /tmp/solution. It will take some additional time. Is that required or was it just for testing?

The binning 4x4 is too much (for ASTAP) with your 3354x2529 sensor. ASTAP works best with images with a resolution between 1.5 MP and 8MP or image height between 1000 and 2500 pixels. For your setting I would recommend either binning 2x2 or binning 1x1. An exposure of 4 seconds is fine.

Clear skies, Han
The following user(s) said Thank You pug916

Please Log in or Create an account to join the conversation.

3 weeks 1 day ago
stash
Gold Boarder
Gold Boarder
Posts: 306
Karma: 4
More
ASTAP astrometry integration #45066
Tested on Ubuntu 18 on AMD 64bit - Called from CCDCIEL now ok :-) TA Han

RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????

Please Log in or Create an account to join the conversation.

3 weeks 22 hours ago
jpaana
Gold Boarder
Gold Boarder
Posts: 214
Karma: 5
More
ASTAP astrometry integration #45071

han.k wrote: Just had a look to your settings. The solution goes to /tmp/solution. The solution will be small .wcs and .ini files. Both could be read for the solution. The parameter -update will copy the source image with the solution added to header to the same /tmp/solution. It will take some additional time. Is that required or was it just for testing?

The binning 4x4 is too much (for ASTAP) with your 3354x2529 sensor. ASTAP works best with images with a resolution between 1.5 MP and 8MP or image height between 1000 and 2500 pixels. For your setting I would recommend either binning 2x2 or binning 1x1. An exposure of 4 seconds is fine.

Clear skies, Han


Thanks for the suggestions! The command line parameters come from Ekos, I don't think I changed anything except switched from offline Astrometry.net to ASTAP, but I'm not sure. Also I don't know how these settings work with ASTAP as I couldn't get it to work yet, but they have been my standard settings for Astrometry.net and work very well. Atik 383L+ is a bit slow to download the full frame but binning helps there. Maybe 2x2 would still be good compromise, have to try how they work.

Remote observatory running Ubuntu 19.10 x64 with ScopeDome 2M, Skywatcher EQ8 and HEQ5, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, USB_Focus V3, Gemini SnapCap, USB_DewPoint, KomaHub

Please Log in or Create an account to join the conversation.

3 weeks 21 hours ago
jpaana
Gold Boarder
Gold Boarder
Posts: 214
Karma: 5
More
ASTAP astrometry integration #45072
Starting ASTAP from Ekos now seems to work without the scroll bar error, can't test how solving actually works thanks to persisting cloud cover. Trying to solve an existing image by loading it within ASTAP itself gives the same scroll bar error than before when pressing solve button.

Remote observatory running Ubuntu 19.10 x64 with ScopeDome 2M, Skywatcher EQ8 and HEQ5, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, USB_Focus V3, Gemini SnapCap, USB_DewPoint, KomaHub

Please Log in or Create an account to join the conversation.

3 weeks 21 hours ago
jpaana
Gold Boarder
Gold Boarder
Posts: 214
Karma: 5
More
ASTAP astrometry integration #45075
Got a small gap in the clouds so could test solving on actual equipment and as you suspected, 4x4 binning was too much, 2x2 worked fine, so I tried 3x3 as well and that seemed to work a bit faster still, so I think I'll start using that. It seems -update flag was checked by default in Ekos options, but works fine without too. But WOW how fast it is, almost instant on my quad core Atom, very well done! My offline Astrometry.net config and catalog set is quite optimized too and not too slow, but I think I'll definitely switch.

Remote observatory running Ubuntu 19.10 x64 with ScopeDome 2M, Skywatcher EQ8 and HEQ5, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, USB_Focus V3, Gemini SnapCap, USB_DewPoint, KomaHub

Please Log in or Create an account to join the conversation.

3 weeks 8 hours ago
han.k
Gold Boarder
Gold Boarder
Posts: 169
Karma: 5
More
ASTAP astrometry integration #45090
The 64 bit version for Raspberry Pi (arm64) had a bug which was related the optimisation factor of the compiler. This is now fixed (prevented). ASTAP is now at 0.9.289 and should work on all platforms.

Han
The following user(s) said Thank You pug916

Please Log in or Create an account to join the conversation.

3 weeks 7 hours ago
han.k
Gold Boarder
Gold Boarder
Posts: 169
Karma: 5
More
ASTAP astrometry integration #45092

jpaana wrote: Got a small gap in the clouds so could test solving on actual equipment and as you suspected, 4x4 binning was too much, 2x2 worked fine, so I tried 3x3 as well and that seemed to work a bit faster still, so I think I'll start using that. It seems -update flag was checked by default in Ekos options, but works fine without too. But WOW how fast it is, almost instant on my quad core Atom, very well done! My offline Astrometry.net config and catalog set is quite optimized too and not too slow, but I think I'll definitely switch.


I'm glad it works for you. I suspect that with 3x3 binning setting the number of tetrahedron matches will be less, so the reliability will be less. But if it works for you keep it for the moment. In case of solve failures go to bin 1x1 or 2x2. If the -update is not required ,yes then remove it. It will speed up the process with one or two seconds.

There is no need to change command line parameters but just in case they are specified here:

www.hnsky.org/astap.htm#astap_command_line

Han
The following user(s) said Thank You pug916

Please Log in or Create an account to join the conversation.

Time to create page: 1.298 seconds