×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Weather radio don't want connect

  • Posts: 50
  • Thank you received: 2
Hi Wolfgang,
It’s with pleasure that I read that you have find a fix for us problem with the nano.
I will go to test as far as possible.

So, I’m reading your weather radio github and I found the fix (delay of 5s) in the Davis anemometer.
So, the fix is ok if I doesn’t use this station?
And to finsih, did you tested the fix with an arduino?

Thanks you very much for your great job!

Olivier
1 year 4 months ago #56731

Please Log in or Create an account to join the conversation.

  • Posts: 883
  • Thank you received: 264
Hi Olivier,
take a look at the pull request: github.com/indilib/indi-3rdparty/pull/165/files

Here you can see that the 5sec delay is in the INDI driver, i.e. its relevant for all using the driver.

It’s tested with Arduinos (Wemos 8266, Nano and Metro Mini)

HTH
Wolfgang
TSA-120 + epsilon-160 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
1 year 4 months ago #56735

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 2
Fantastic!
Thanks for the precision.
I will look that, it’s a good thing to learn.
And I will tey as soon as possible the bew driver and I come back to say you.
Have a nice day
1 year 4 months ago #56742

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 2
Hi Wolfgang,

So I've updated my system and the firmware and the driver is OK.
Indi driver is connected to my arduino in 1 time!! ouaou!!! so cool!
I've just an one issue.
After I check and set my parameters, it's impossible to save my config in the option tab. The button stay inactif and when I restart kstars / ekos I must to parameter my sensors one more time.
It's not a very big problem but if you have aa soultion I will be happy :)
I tested with my wndows PC and my tinkerboard. It's the same issue.

thank you very much for all the job!!! great!!!
The following user(s) said Thank You: Wolfgang Reissenberger
Last edit: 1 year 4 months ago by Alonso.
1 year 4 months ago #56774

Please Log in or Create an account to join the conversation.

  • Posts: 883
  • Thank you received: 264
That's really odd, I do not have an explanation for this. How do you start indiserver?

Wolfgang
TSA-120 + epsilon-160 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
1 year 4 months ago #56790

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 2
Hi,

So, to start indiserer I lunch kstars, then ekos and I click on the arrow to start indi.
All drivers starts and I begin my session.
After checked others buttons, there is also the debug button that stay inactif.

Maybe that it’s the installation of weather radio:
To update, i have proceded like that:
Download from your girhub.
Copy the indiduino folder to indi-3rdparty of my indi folder.
I create a build folder and I follow the instrctions to create indi driver

Maybe I will wait the update from official girhub indilib.

What do you think?

Olivier
1 year 4 months ago #56791

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 2
Hi Wolfgang,

So I resolved the issue. I have deleted the config files in the folder /home/"name"/.indi
there are 2 config files and after delete I can to save my parameters.
So, it"s a good news for me!!!
but, because there is a but ^^, when I save my parameters, the % of warning return always to default. For example, for the cloud, I have enter 0 to min and 100 to max, then i have put 30% for warning. If I stop and quit kstars then i restart it, the % is return to 50%.
I have checked the weather radio conf xml file in the /.indi folder. Maybe there is an other location to the config file.

And again a big thanks for all this job. :D

Olivier
The following user(s) said Thank You: Wolfgang Reissenberger
Last edit: 1 year 4 months ago by Alonso.
1 year 4 months ago #56817

Please Log in or Create an account to join the conversation.

  • Posts: 883
  • Thank you received: 264
Salut Olivier,
are you sure that it does not load your settings? I did exactly the same and everything worked fine:

Maybe you look into the wrong field. The 50% on the right hand side are the new value that will be applied when you press "Set". But the current value is "30%", which I loaded from the config file.

Wolfgang
TSA-120 + epsilon-160 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
1 year 4 months ago #56826
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 554
  • Thank you received: 138
What seems to happen is that at least some Arduinos do a reset when the usb serial port connects, then looks for program upload commands. I've found that a two second delay after connect before trying to communicate is enough.
The following user(s) said Thank You: Wolfgang Reissenberger
1 year 4 months ago #56828

Please Log in or Create an account to join the conversation.

  • Posts: 883
  • Thank you received: 264
Ah, interesting, that sounds like an explanation. Since I hardcoded it, I took 5s to be on the safe side.
TSA-120 + epsilon-160 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
1 year 4 months ago #56835

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 2
Hi,
You were right!
I’m very bad!! All is ok!!
Sorry for that! I’m tired!
Olivier
Last edit: 1 year 4 months ago by Alonso.
1 year 4 months ago #56840

Please Log in or Create an account to join the conversation.

  • Posts: 50
  • Thank you received: 2
So,

I'm happy to say you that all is good!! the indi driver and the web server!! ouahhhh very cool!!
It's perfect.

This is my weather radio web site:
176.135.77.1/weatherradio/

I've juste one question:
when I go to the web site, I must to click on the time range (6h - 1d - 7d or 30d) to see the values and the grpahs.
if I will go on your website the values is instantaneous printed.

So, do you have an idea of why I have this effect?? thank you very much.

Olivier
1 year 4 months ago #56905

Please Log in or Create an account to join the conversation.

Time to create page: 1.614 seconds