×
INDI Library v1.8.5 Released (19 Apr 2020)

April 2020 release of INDI Library v1.8.5 introduces new drivers while providing fixes and improvements to existing devices and core framework.

Weather radio don't want connect

1 month 6 days ago 1 month 6 days ago by astrolivier76.
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #56461
hmm I don't understand,

why, when I send the command "p" the serial monitor send me the value but if i send a new "p" the serial monitor not responding... and whatever the command send the serial monitor not responding, I must to reset arduino.
I think it's a similar problem with kstars no?

and the second send return me always an error in the text; look:

Attachments:

Please Log in or Create an account to join the conversation.

1 month 6 days ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 599
Karma: 6
More
Weather radio don't want connect #56462
Salut Olivier,
the easiest way to drill down where the connection problem comes from is to deactivate the sensors in the firmware and stepwise re-activating them. This is directly controlled from the config.h. The INDI driver itself is flexible, you do not need to change anything there.

As soon as we know which sensor is the one creating delays, we need to check where this delay comes from. It could also be that one of the sensors is not working properly - maybe due to a wiring/soldering problem or it is simply broken.

Hope that helps. Maybe it's easier if you send me a PN here in the forum, since the details might not be of general interest.

A bientôt
Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

1 month 6 days ago
G_Gagnon
Expert Boarder
Expert Boarder
Posts: 126
Karma: 2
More
Weather radio don't want connect #56464
Olivier and Wolgang,

I am not sure that there is a defective or badly connected sensor as I observed the same behavior with my Nano version but not with the Wemos version of Weather Radio.

If there is a sensor I would suspect of causing the delay, it is the TSL2591 as, depending of sky brightness, its integration time may not be negligible (600ms) and the sensor may need its integration time and gain to be adjusted a number of times in order to give a meaningful reading, particularly in darker conditions.

Please Log in or Create an account to join the conversation.

1 month 5 days ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #56467
I agree that G_Gagnon said.
If I send the example for each sensor all send me the goods values
If I send indiduino I have also the good value
But not with the weather radio firmware or indi driver

I have check all sensor one by one and it's always the same issue.
the problem start with the arduino firmware because if I send twice "p" or "w" or "v" the arduino nano block and I must to reset it.

So I think the indi driver send this letters via Serial and the arduino block.

I hope that the 1.4 fix the pb.

If I haven't the choice I will buy a wemos D1 mini to test and re solder all .

PS: when you say speak via PN how to to? Sorry I don't how to do.
My mail is "This email address is being protected from spambots. You need JavaScript enabled to view it." if you prefer :)

thanks

Please Log in or Create an account to join the conversation.

1 month 5 days ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 599
Karma: 6
More
Weather radio don't want connect #56470
I cannot test it currently with my old Nano, it seems to be broken. By next weekend I can give you an update.

Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

1 month 5 days ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 599
Karma: 6
More
Weather radio don't want connect #56475
OK, I can reproduce your problem with a Nano Every, after the second request for weather data, the Arduino seems to hang.

Let's see if I can get it fixed...

Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

1 month 5 days ago 1 month 5 days ago by sterne-jaeger.
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 599
Karma: 6
More
Weather radio don't want connect #56479
Hi folks,
I think I found the problem. It looks like on some Arduinos its a problem when a function defined as String does not invoke a return.

To fix it, please correct parseInput() in weatherradio.ino to type void and correct the return value three lines below accordingly:
void parseInput() {
  // ignore empty input
  if (input.length() == 0)
    return;
...

It will be fixed in V 1.4. Here you can see this change: github.com/indilib/indi-3rdparty/pull/16...ea6beed1d7cf6980069b

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

1 month 5 days ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #56486
Hi Wolfgang,

Thank you to do necessary. You're very reagent wouaahhh!! So good.
I can't to test in the day but tonight i will try and I say you if it's OK.

Have a nice day

Olivier

Please Log in or Create an account to join the conversation.

1 month 5 days ago
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #56513
Hi Wolfgang,

I tested the fix and the problem is'nt resolve
I have always the time out and in the serial monitor, if I send a command "w" i receive the good values but if I send an another command the arduino not responding and I must to restart it

Sorry it's not the solution of the problem

Please Log in or Create an account to join the conversation.

1 month 4 days ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 599
Karma: 6
More
Weather radio don't want connect #56524
Hi Olivier,
yes, it's somehow strange. It looks like there is a problem with the caching that does not work properly on some Arduinos. I've reworked it today.

The latest version is available from my fork of INDI 3rdparty: https://github.com/sterne-jaeger/indi-3rdparty/tree/weatherradio-v_1.5

For simplicity, I attach the latest version here.

Hope this is working now. Otherwise I have to wait for my Nano to arrive...

Cheers
Wolfgang

File Attachment:

File Name: weatherradio_1.5.zip
File Size:13 KB

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10
Attachments:

Please Log in or Create an account to join the conversation.

1 month 4 days ago 1 month 4 days ago by astrolivier76.
astrolivier76
Senior Boarder
Senior Boarder
Posts: 48
More
Topic Author
Weather radio don't want connect #56535
Hi Wofgang,

I uploaded the new firmware and it's Ok.
The first time I due to click two times to connect it but after connection I can to connect all sensors and read it.
in the Options I selected all sensors, after aplicated parameters in parameters tab, in the weather tab of EKOS I can see values and I can see if the weather is sage or not with the not safety parametrer, for ex 100% cloud!! It's a great job!! wouaoo!

So, I have to try to manager weather in simulation with a eqmod simulator, ccd simulator and roll off simulaor.
Can you explain me what are the park policies to applied to, first park mount then park dome, if the weather passed from safe to unsafe.

Thank you very much.

Olivier

Please Log in or Create an account to join the conversation.

1 month 3 days ago
sterne-jaeger
Platinum Boarder
Platinum Boarder
Posts: 599
Karma: 6
More
Weather radio don't want connect #56547
Aaaah, good to hear that it is working fine.

Regarding parking: I'm not the expert, I have only a wooden pole and no dome.

I've written the Observatory tab of EKOS, therefore I know this part quite well. In the Observatory tab, you can configure how the observatory should react upon warnings and alerts including thresholds. If you for example check the "Alerts" checkbox, you can select whether the dome should park after x seconds when the weather status turns to "ALERT".

For parking the scope, you can configure the dome device that the scope should snoop (i.e. listen). There you need to type our rolloff roof device name and select, how the scope should react upon the dome parking/unparking.

But better try it out with the simulators.

And be careful, better try twice :-)

Cheers
Wolfgang

TSA-120 + FSQ-85 + GSO 150/750 | Avalon Linear + M-zero | Moravian G2-8300 + ASI 1600mm pro + ASI 294mc pro | KStars/INDI on Raspberry Pi 4 with Raspbian 10

Please Log in or Create an account to join the conversation.

Time to create page: 0.780 seconds