×

INDI Library v1.8.0 is Released (27 Jul 2019)

INDI Library v1.8.0 is mostly a maintenance release to fix a few bugs in several drivers.

Skywatcher AZ GTi with Ekos

  • Posts: 119
  • Thank you received: 23

Replied by tkottary on topic Skywatcher AZ GTi with Ekos

Looks like i had some issue with tinkerboard , after restarting i am able to connect to port via udp on terminal.

nafa@tinkerboard:~/.local/share/kstars/logs/2018-07-15$ nc -u -v 192.168.4.1 11880
Connection to 192.168.4.1 11880 port [udp/*] succeeded!

ekos is unable to connect though. Debug logs:

[2018-07-15T18:02:06.690 PDT DEBG ][ org.kde.kstars.indi] - SynScan : "[DEBUG] Connection successful, attempting handshake... "
[2018-07-15T18:02:08.692 PDT DEBG ][ org.kde.kstars.indi] - SynScan : "[DEBUG] Handshake failed. "
[2018-07-15T18:02:08.693 PDT DEBG ][ org.kde.kstars.ekos] - SynScan is disconnected.
[2018-07-15T18:03:45.215 PDT DEBG ][ org.kde.kstars.indi] - SynScan : "[DEBUG] Connection successful, attempting handshake... "
[2018-07-15T18:03:47.218 PDT DEBG ][ org.kde.kstars.indi] - SynScan : "[DEBUG] Handshake failed. "
[2018-07-15T18:03:47.218 PDT DEBG ][ org.kde.kstars.ekos] - SynScan is disconnected.
1 year 1 month ago #27475

Please Log in or Create an account to join the conversation.

  • Posts: 122
  • Thank you received: 9

Replied by RogueSquadron on topic Skywatcher AZ GTi with Ekos

This is as far as we got. Jasem said, it is hard to log or monitor on MacOS, but I got my Raspberry now, so maybe I will try to connect again on the Raspberry.

Let us know, if you proceed somehow.
Skywatcher Newton 200/1000 on EQ6-R
Skywatcher Mak 105/1300 on AZ GTi
StellarMate @ Raspberry Pi 3B+
ASI 290 MC guiding cam on APM 60 ImageMaster
Canon 7D DSLR or ASI 183 MC Pro

1 year 1 month ago #27477

Please Log in or Create an account to join the conversation.

  • Posts: 119
  • Thank you received: 23

Replied by tkottary on topic Skywatcher AZ GTi with Ekos

sure, I have also emailed synscan developers , hopefully they will get back with some information. I also captured the Wireshark wifi data from windows ,which ill attach later today.
1 year 1 month ago #27483

Please Log in or Create an account to join the conversation.

  • Posts: 119
  • Thank you received: 23

Replied by tkottary on topic Skywatcher AZ GTi with Ekos

Got response from synScan Team:


The Indi driver should talk with the SynScan App, not the mount.

The SynScan App listens the SynScan hand control serial command protocol(from a telescope mount driver) via TCP port 11882. You should use the IP address of the device that runs the SynScan App(It might be 192.168.4.2 if it is the first device that connects to the mount’s access point).

The UDP port 192.168.4.1:11880 is for the mount’s motor controller.
1 year 1 month ago #27488

Please Log in or Create an account to join the conversation.

  • Posts: 119
  • Thank you received: 23

Replied by tkottary on topic Skywatcher AZ GTi with Ekos

Attaching Wireshark data for various scenarios.It looks like we are unable to reach to destination port(?)

Tired with RPI3 connecting to synscan and iPhone connecting to SynScan wifi @ 192.168.4.2 11882 tcp .
Tried with SynScan and Skywatcher Alt AZ drivers of Indi. Both the times made sure SynScan app was live (not in background)
1 year 1 month ago #27491
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 122
  • Thank you received: 9

Replied by RogueSquadron on topic Skywatcher AZ GTi with Ekos

I tried both as well, did not work for me either. When trying to connect to the iPhone I could not reach anything.

I wonder how WiFi dongle works for the EQ-mounts, because they are using the same protocol and app on the phones.

What might also be a solution is to connect a handset to the Alt AZ and trying to connect to the handset via cable.
Skywatcher Newton 200/1000 on EQ6-R
Skywatcher Mak 105/1300 on AZ GTi
StellarMate @ Raspberry Pi 3B+
ASI 290 MC guiding cam on APM 60 ImageMaster
Canon 7D DSLR or ASI 183 MC Pro

1 year 1 month ago #27492

Please Log in or Create an account to join the conversation.

Replied by knro on topic Skywatcher AZ GTi with Ekos

From what I understood, you need to connect to the phone running the Synscan app, and NOT the WiFi dongle IP. What's your phone IP address? and what's the WiFi dongle IP address?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 1 month ago #27510

Please Log in or Create an account to join the conversation.

  • Posts: 122
  • Thank you received: 9

Replied by RogueSquadron on topic Skywatcher AZ GTi with Ekos

I tried both. Usually when you use the build it Hotspot, the mount starts with 192.168.4.1 and the phone gets 192.168.4.2. I did manage to get a connection to my phone, but the device driver crashed after connecting.
Skywatcher Newton 200/1000 on EQ6-R
Skywatcher Mak 105/1300 on AZ GTi
StellarMate @ Raspberry Pi 3B+
ASI 290 MC guiding cam on APM 60 ImageMaster
Canon 7D DSLR or ASI 183 MC Pro

1 year 1 month ago #27511

Please Log in or Create an account to join the conversation.

Replied by knro on topic Skywatcher AZ GTi with Ekos

and what's your own IP address? i.e. the IP address of the machine running INDI driver?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 1 month ago #27517

Please Log in or Create an account to join the conversation.

  • Posts: 119
  • Thank you received: 23

Replied by tkottary on topic Skywatcher AZ GTi with Ekos

To be clear this is what I tested:

Boot up the mount and connect to the iPhone having synscan app to Mount

Mount Ip is 192.168.4.1, iPhone got 192.168.4.2.

Now again here tested both ways:
Indi on RPI was connected to my home wifi that had 192.168.1.12.
indi on RPI connected to Mount wifi then which it got 192.168.4.3

in the ekos I had chosen serial , set ip to 192.168.4.2 TCP 11882 and all times connections failed.
1 year 1 month ago #27524

Please Log in or Create an account to join the conversation.

Replied by knro on topic Skywatcher AZ GTi with Ekos

Yes, INDI on RPI3 needs to be on the mount WiFi network in order to communicate over the same network.

Please turn on Mount logging in Ekos, and then attach it here.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
1 year 1 month ago #27525

Please Log in or Create an account to join the conversation.

  • Posts: 119
  • Thank you received: 23

Replied by tkottary on topic Skywatcher AZ GTi with Ekos

Attached the logs. Some more debug driver logs as below.

tar@tar-desktop:~/.indi/logs/2018-07-18/indi_synscan_telescope$ cat indi_synscan_telescope_02:45:30.log
INFO 33.666106 sec : Session log file /home/tar/.indi/logs/2018-07-18/indi_synscan_telescope/indi_synscan_telescope_02:45:30.log
INFO 41.036448 sec : Connecting to 192.168.4.2@11882 ...
ERROR 41.106719 sec : Failed to connect to mount 192.168.4.2@11882: Connection refused.
INFO 42.286021 sec : Connecting to 192.168.4.2@11882 ...
ERROR 42.335596 sec : Failed to connect to mount 192.168.4.2@11882: Connection refused.
tar@tar-desktop:~/.indi/logs/2018-07-18/indi_synscan_telescope$

tar@tar-desktop:~/.indi/logs/2018-07-18/indi_synscan_telescope$ cat indi_synscan_telescope_02:34:37.log
INFO 8.353158 sec : Session log file /home/tar/.indi/logs/2018-07-18/indi_synscan_telescope/indi_synscan_telescope_02:34:37.log
INFO 35.142521 sec : Connecting to 192.168.4.2@11882 ...
ERROR 35.156510 sec : Failed to connect to mount 192.168.4.2@11882: Connection refused.
INFO 39.312678 sec : Connecting to 192.168.4.2@11882 ...
ERROR 39.320977 sec : Failed to connect to mount 192.168.4.2@11882: Connection refused.
INFO 50.982383 sec : Connecting to 192.168.4.2@11881 ...
DEBUG 50.982764 sec : Connection successful, attempting handshake...
INFO 51.002177 sec : Synscan Mount not responding
DEBUG 51.002343 sec : Handshake failed.
INFO 52.882429 sec : Connecting to 192.168.4.2@11881 ...
DEBUG 52.882732 sec : Connection successful, attempting handshake...
INFO 52.909325 sec : Synscan Mount not responding
DEBUG 52.909613 sec : Handshake failed.

Ping the mount
tar@tar-desktop:~$ ping 192.168.4.1
PING 192.168.4.1 (192.168.4.1) 56(84) bytes of data.
64 bytes from 192.168.4.1: icmp_seq=1 ttl=255 time=4.35 ms
64 bytes from 192.168.4.1: icmp_seq=2 ttl=255 time=4.05 ms
64 bytes from 192.168.4.1: icmp_seq=3 ttl=255 time=5.84 ms
^C
--- 192.168.4.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 4.059/4.755/5.847/0.781 ms

tar@tar-desktop:~$ ping 192.168.4.2
PING 192.168.4.2 (192.168.4.2) 56(84) bytes of data.
64 bytes from 192.168.4.2: icmp_seq=1 ttl=64 time=15.7 ms
64 bytes from 192.168.4.2: icmp_seq=2 ttl=64 time=43.7 ms
64 bytes from 192.168.4.2: icmp_seq=3 ttl=64 time=23.5 ms
^C
--- 192.168.4.2 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 15.713/27.699/43.796/11.828 ms

tar@tar-desktop:~$ nc -v 192.168.4.2 11880
nc: connect to 192.168.4.2 port 11880 (tcp) failed: Connection refused
tar@tar-desktop:~$ nc -v 192.168.4.2 11882
nc: connect to 192.168.4.2 port 11882 (tcp) failed: Connection refused
tar@tar-desktop:~$ nc -v 192.168.4.2 11881
nc: connect to 192.168.4.2 port 11881 (tcp) failed: Connection refused

tar@tar-desktop:~$ nc -v -u 192.168.4.1 11882
tar@tar-desktop:~$ nc -v -u 192.168.4.2 11882
tar@tar-desktop:~$ nc -v -u 192.168.4.2 11881
Connection to 192.168.4.2 11881 port [udp/*] succeeded!
Unknown,XUnknown,XUnknown,XUnknown,XUnknown,X
Unknown,
^C
Last edit: 1 year 1 month ago by tkottary.
1 year 1 month ago #27539
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.208 seconds