Jordi Artigas replied to the topic 'Ekos on Mac OS X ?' in the forum. 3 years ago

rlancaste wrote:

jeam wrote: I can't see this line in terminal: ==> /usr/bin/sudo /bin/mkdir -p /Library/Caches/Homebrew
And Password is not seen, neither.

I try to lunch ruby command with sudo but whith the same result.


see if this helps. brew.sh maybe I am missing something.

/usr/bin/ruby -e "$(curl -fsSL raw.githubusercontent.com/Homebrew/install/master/install )"

Great!!!

Now Ekos can solve offline perfectly. To resolve I must to install this pakages from terminal:

brew install netpbm

pip install numpy

sudo pip install pyfits

Thanks you very much

Read More...

Jordi Artigas replied to the topic 'Ekos on Mac OS X ?' in the forum. 3 years ago

rlancaste wrote: see if this helps. brew.sh maybe I am missing something.

/usr/bin/ruby -e "$(curl -fsSL raw.githubusercontent.com/Homebrew/install/master/install )"


Now instalation works fine, great thanks.

Later, I try to solve a simulated image, offline from Astrometry.

Thanks very much

Read More...

Jordi Artigas replied to the topic 'Ekos on Mac OS X ?' in the forum. 3 years ago

I can't see this line in terminal: ==> /usr/bin/sudo /bin/mkdir -p /Library/Caches/Homebrew
And Password is not seen, neither.

I try to lunch ruby command with sudo but whith the same result.

Read More...

Jordi Artigas replied to the topic 'Ekos on Mac OS X ?' in the forum. 3 years ago

When I execute those commands I get this result:

iMac-de-Jordi:Library jeam$ ruby -e "$(curl -fsSL raw.githubusercontent.com/Homebrew/install/master/install)" < /dev/null 2> /dev/null
==> This script will install:
/usr/local/bin/brew
/usr/local/share/doc/homebrew
/usr/local/share/man/man1/brew.1
/usr/local/share/zsh/site-functions/_brew
/usr/local/etc/bash_completion.d/brew
/usr/local/Homebrew
iMac-de-Jordi:Library jeam$ brew install python
-bash: brew: command not found
iMac-de-Jordi:Library jeam$
iMac-de-Jordi:Library jeam$ brew install netpbm
-bash: brew: command not found
iMac-de-Jordi:Library jeam$

It seems that brew is not found.

Read More...

Jordi Artigas replied to the topic 'Ekos on Mac OS X ?' in the forum. 3 years ago

It seems it is installed:

iMac-de-Jordi:Library jeam$ pip install pyfits
Requirement already satisfied: pyfits in /Library/Python/2.7/site-packages
Requirement already satisfied: numpy in /System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python (from pyfits)

How can I install netpbm via homebrew? Sorry I don't know what homebrew is?

Thanks!!!

Read More...

Jordi Artigas replied to the topic 'Ekos on Mac OS X ?' in the forum. 3 years ago

Hi again,

I'm trying to use internal Astromety solver inside Ekos, but it's always failing. If I use external solver it works fine. I'm using internal Ekos Simulators.

From inside Ekos I get this log:

2017-01-22T19:33:09.264 - DEBG - Alignment: "Capturing image..."
2017-01-22T19:33:11.288 - DEBG - Alignment: "Image received."
2017-01-22T19:33:11.302 - DEBG - Alignment: "Starting solver..."
2017-01-22T19:33:11.307 - DEBG - Alignment: "/Applications/kstars.app/Contents/MacOS/astrometry/bin/solve-field --no-verify --no-plots --resort --downsample 2 -O -L 17.39 -H 24.0257 -u aw -3 0.1875 -4 90 -5 30 -W /var/folders/_x/yd53fmss1x96gs83jbw0hph80000gn/T/solution.wcs /var/folders/_x/yd53fmss1x96gs83jbw0hph80000gn/T/fitsORC791"
2017-01-22T19:33:11.326 - DEBG - Alignment: "Reading input file 1 of 1: \"/var/folders/_x/yd53fmss1x96gs83jbw0hph80000gn/T/fitsORC791\"..."
2017-01-22T19:33:11.405 - DEBG - Alignment: "Solver failed. Try again."

If I run the same comand from the Teminal it returns this:

iMac-de-Jordi:Library jeam$ /Applications/kstars.app/Contents/MacOS/astrometry/bin/solve-field --no-verify --no-plots --resort --downsample 2 -O -L 17.39 -H 24.0257 -u aw -3 0.1875 -4 90 -5 30 -W /var/folders/_x/yd53fmss1x96gs83jbw0hph80000gn/T/solution.wcs /var/folders/_x/yd53fmss1x96gs83jbw0hph80000gn/T/fitsORC791
Reading input file 1 of 1: "/var/folders/_x/yd53fmss1x96gs83jbw0hph80000gn/T/fitsORC791"...
/bin/sh: pnmfile: command not found
augment-xylist.c:589:backtick Failed to run command: pnmfile /tmp/tmp.ppm.8LobBz
ioutils.c:563:run_command_get_outputs Command not found: pnmfile /tmp/tmp.ppm.8LobBz
iMac-de-Jordi:Library jeam$

I suppose that my system is missing some component, but I don't know which.

Any help it's wellcome.

Jeam

Read More...

Jordi Artigas created a new topic ' Exposure failed to save image... Directory not found' in the forum. 3 years ago

Hi to all,
I'm new in this forum.
I'm using Indi in Raspberry Pi 3 and Ubuntu Mate system. I'm trying to use a Canon 350 but when I take a photo I have next error:

2017-01-05T00:01:17: Exposure failed to save image... Directory not found
2017-01-05T00:01:17: Error downloading image from camera: Directory not found
2017-01-05T00:01:16: Starting 1 sec exposure
2017-01-05T00:01:04: Please update the camera pixel size in the Image Info section. The camera resolution will be updated after the first exposure is complete.
2017-01-05T00:01:04: Detected Canon Inc. Model Canon EOS 350D DIGITAL.
2017-01-05T00:01:04: Canon DSLR is online.

I'm cheking in the configuration the download path and it seems correct: /home/username

Do you have any idea?

Best regards

jeam

Read More...

nMAC thanked Jordi Artigas in topic Ekos on Mac OS X ? 3 years ago

Jordi Artigas thanked nMAC in topic Ekos on Mac OS X ? 3 years ago

Jordi Artigas replied to the topic 'Ekos on Mac OS X ?' in the forum. 3 years ago

Hi,

I'm very new using Indi, KStars and Ekos. I was using it on Ubuntu only, at home, with no connection to telescope right now. I have one Raspberry Pi 3 with Indi, I use it as indi server and it works fine with Canon 450D, by the moment it is all I can test.

I download your DMG to try to use in iMac Sierra. It works fine with this equipment.

Thanks for your great work!

Jeam

Read More...