×

INDI Library v1.8.9 Released (01 Mar 2021)

INDI monthly update. In addition to driver improvements, major code refactoring is in progress by @pawel-soja to modernize and improve INDI aging code.

New forum users, please go here first: indilib.org/forum/new-forum-users.html

KStars v3.4.3 Released

  • Posts: 122
  • Thank you received: 25

Replied by Marc2b on topic KStars v3.4.3 Released

Now, my own problems :

1/ I'm using Kstars with the dark theme "Black Body". When I quit and then restart, the soft comes back with an incomplete white menu and I have to set my theme again.
it is very unpleasant when you're in the dark and have your vision adapted because of the crude white light.



2/ I have 3 problems with indiwebmanager. (The last version including agent)

- I can't change the default 'root' user in the indiwebmanager.service or it refuses my connection.
- If I connect through indiweb, the indiserver and drivers are launched but everything stalls then. I'can't even unpark my mount.
If I start manually the indiserver and the drivers through an ssh cnx, everything works fine.
- In simulation mode, it says there is no GSC available. (It works with the workaround above)

- Marc
The following user(s) said Thank You: TallFurryMan
Last edit: 9 months 7 hours ago by Marc2b.
9 months 7 hours ago #57160
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 1092
  • Thank you received: 170

Replied by El Corazon on topic KStars v3.4.3 Released

Marc2b wrote: El Corazon says :

[2020-07-19T21:17:09.536 CDT INFO ][ org.kde.kstars.indi] - iOptron CEM60 : "[WARNING] Cannot unpark mount when dome is locking. See: Dome Policy in options tab. "

Just as the message says, go to the indi panel/your mount/options and simply click "Dome Ignored". Save and reload and you're done. ;)

- Marc



Done that, of course, but have been unable to test since it is cloudy again now. But if that is all that is required for fixing it, then that's easy enough, of course. Can you confirm, that that is all that's required, Marc? Doug's experience suggested something else.

Jo
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
9 months 6 hours ago #57165

Please Log in or Create an account to join the conversation.

  • Posts: 122
  • Thank you received: 25

Replied by Marc2b on topic KStars v3.4.3 Released

El Corazon wrote:

Marc2b wrote: El Corazon says :

[2020-07-19T21:17:09.536 CDT INFO ][ org.kde.kstars.indi] - iOptron CEM60 : "[WARNING] Cannot unpark mount when dome is locking. See: Dome Policy in options tab. "

Just as the message says, go to the indi panel/your mount/options and simply click "Dome Ignored". Save and reload and you're done. ;)

- Marc



Done that, of course, but have been unable to test since it is cloudy again now. But if that is all that is required for fixing it, then that's easy enough, of course. Can you confirm, that that is all that's required, Marc? Doug's experience suggested something else.

Jo


Hi Jo,

If your nights are cloudy you can verify it works with the indi_simulator_telescope driver (Telescope Simulator in the profile editor )

- Marc
9 months 6 hours ago #57170

Please Log in or Create an account to join the conversation.

Replied by knro on topic KStars v3.4.3 Released

The "Mount cannot unpark due to dome" issue was fixed in INDI, please update!
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
The following user(s) said Thank You: TallFurryMan, El Corazon, pug916
9 months 5 hours ago #57171

Please Log in or Create an account to join the conversation.

  • Posts: 149
  • Thank you received: 49

Replied by Gilles on topic KStars v3.4.3 Released

Tested last night IRL
Same problem with dome locking stuff, quickly solved :-)
i've tested multistar SEP guiding, and did'nt noticed any improvement on my guiding accuracy but it needs more testing obviously
i tried Backlash measurment for DEC axis, but i could'nt achieve any calibration, i have to understand what happens (possibly mount problems)
BTW calibration plot is really usefull !
i also tried Bahtinov focus assistant, but also need more testing : need to understand what graph shows
(it's also hard to use with manual focus)

Anyway :
Great work ! (again)
9 months 5 hours ago #57172

Please Log in or Create an account to join the conversation.

  • Posts: 1092
  • Thank you received: 170

Replied by El Corazon on topic KStars v3.4.3 Released

I assume it was fixed in the nightly repository only and not in the stable release?

Or do I need to compile Indi manually?
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
9 months 5 hours ago #57174

Please Log in or Create an account to join the conversation.

  • Posts: 501
  • Thank you received: 49
I don't have a dome but cannot unpark my mount either.
How do I download nightlies on Raspbian (Srellarmate 1.5.3)?
Max S.

RPI 4 B (4Gb) with SMate
Nikon D5500 H-a modified. Nikon D5500 stock
AT72EDII, TPO RC6
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi x 2
SW HEQ5
RST-135
8 months 4 weeks ago #57191

Please Log in or Create an account to join the conversation.

  • Posts: 252
  • Thank you received: 17

Replied by phomer60 on topic KStars v3.4.3 Released

Marc,

I think the issue is more than just resetting the Dome Ignored flag.
If you don't have a Dome then why is it happening and secondly what triggered this in the first place?

Paul
8 months 4 weeks ago #57192

Please Log in or Create an account to join the conversation.

  • Posts: 1092
  • Thank you received: 170

Replied by El Corazon on topic KStars v3.4.3 Released

I updated Kstars from sources and Indi from nightly. Dome is now set to 'Ignored' by default. The mount unparks, parks and slews normally, but I need to wait for clear weather again to test it in the field. So far it looks good.
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
8 months 4 weeks ago #57194

Please Log in or Create an account to join the conversation.

  • Posts: 693
  • Thank you received: 92

Replied by DerPit on topic KStars v3.4.3 Released

Running self-compiled INDI and KStars (git as of July 20) I have two issues:
  1. Using PHD2 for guiding, the guide graph now gets reset after every dither operation (erase old data, start with time stamp 0)
  2. Meridian flip, if happening within a series, seems to lose/overwrite an image. It saves Light_010.fits as "Received image 10 out of 45.", then does the flip (successfully), but the next image gets written with the same name again, Light_010.fits, and the log says "Received image 11 out of 45."

Relevant cutout of the log is attached.
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
8 months 4 weeks ago #57206
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 335
  • Thank you received: 98

Replied by dmsummers on topic KStars v3.4.3 Released

@DerPit: About the guide graph being reset, I too immediately noticed that issue after updating, but after using it for a night, I quickly got used to it and like it. The quality of each exposure is easily visualized simply by watching the scatter during the exposure. Maybe as opposed to reversion, it might be nice to have a checkbox to enable/disable this new behavior vs the old behavior (as a feature)! Cheers, Doug
RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.
Last edit: 8 months 4 weeks ago by dmsummers.
8 months 4 weeks ago #57210

Please Log in or Create an account to join the conversation.

  • Posts: 1092
  • Thank you received: 170

Replied by El Corazon on topic KStars v3.4.3 Released

DerPit wrote: Running self-compiled INDI and KStars (git as of July 20) I have two issues:

  1. Using PHD2 for guiding, the guide graph now gets reset after every dither operation (erase old data, start with time stamp 0)
  2. Meridian flip, if happening within a series, seems to lose/overwrite an image. It saves Light_010.fits as "Received image 10 out of 45.", then does the flip (successfully), but the next image gets written with the same name again, Light_010.fits, and the log says "Received image 11 out of 45."

Relevant cutout of the log is attached.


If you elect in the capture module to record the time at which the exposure was taken, it will not overwrite the previous exposure with the same number, as the time will be different and the file name will thus be unique. I routinely collect data from multiple nights into the same folder where the file numbers are reset at the beginning of each session, but because date and time are different, there is no file conflict.

Jo
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
The following user(s) said Thank You: pug916
8 months 4 weeks ago #57211

Please Log in or Create an account to join the conversation.

Time to create page: 3.078 seconds