×

INDI Library v1.9.6 Released (21 May 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

KStars v3.4.3 Released

  • Posts: 839
  • Thank you received: 108
@Doug: Yeah, I wasn't sure if that was intended or accidental. What I am missing now is the information how long the dither operation took. I'm doing RGB with short exposure times, so I like to have an overview how much time is spent for dithering. So I'd definitely welcome an option to get the old behavior back. Either by a bugfix, or a new feature button :P

@Jo: Sure there are ways to get around it, but I think/hope you'd agree that not advancing the image name counter is a bug, is it? ;)
openSUSE Tumbleweed KStars git INDI git
GPDX+EQMOD, CEM60EC, ASI2600/1600/290mini+EFW+EAF
1 year 11 months ago #57216

Please Log in or Create an account to join the conversation.

  • Posts: 380
  • Thank you received: 113

Replied by Doug S on topic KStars v3.4.3 Released

@DerPit, We're still on the same page (for a checkbox,button), but a second related thought is about the new LogViewer. I use PHD2, and the log viewer shows the dither timing. I'm not sure if you are using PHD2 or not. If you're using the internal guider, you might check the LogViewer to see if the dither timing has been implemented in the kstars/ekos guide log. It doesn't help for real-time, but the info might not be lost...
RASA11, Celestron CGX-L, ASI183mc Pro, 60mm guider + ASI290mm mini, ASI EAF focuser, PPB, Rpi4-4Gb+SSD, Powered USB3 hub, hardwire Ethernet.
1 year 11 months ago #57217

Please Log in or Create an account to join the conversation.

  • Posts: 56
  • Thank you received: 1

Replied by Serge CLAUS on topic KStars v3.4.3 Released

Hello,
I just tested with lx200_onstep in simulation mode and same problem: kstars crashes for park/unpark.
Tested with lx200_teenastro (simulator): OK
Test with EQmod (simulator): OK
Test with the previous version of lx200_onstep: OK
I think there is really a problem with the latest version of lx200_onstep.

However, the latest version of lx200_onstep works perfectly with "skychart".

Just tested with kstars 3.4.2: same result with lthe last lx200_onstep -> crash on park/unpark.
Last edit: 1 year 11 months ago by Serge CLAUS.
1 year 11 months ago #57225

Please Log in or Create an account to join the conversation.

  • Posts: 821
  • Thank you received: 396

Replied by Hy Murveit on topic KStars v3.4.3 Released

Re the dome-ignored setting, I git pulled the latest indi and kstars yesterday (July 24, post 3.4.3 release) and compiled and ran the latest code and ran into the same problem as was reported in this thread.
The mount wouldn't slew "because of the dome" (but I don't have a dome). I followed the advice on this thread and found the indi eqmod control-->options tab-->DomeIgnored,
and then "Save Configuration", and that fixed the issue. Thanks! However, the default still seems to be Dome Locks.

Hy
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
1 year 11 months ago #57350

Please Log in or Create an account to join the conversation.

  • Posts: 359
  • Thank you received: 26

Replied by Paul on topic KStars v3.4.3 Released

Hy,

If you do another pull this should work as Jasem has now fixed it.

Paul
Losmandy G11 with Gemini 2 controller
QSI 583/683 monochrome camera with filter wheel
Starlight Xpress Lodestar X2 guide camera
Microtouch Focuser controlled using Arduino UNO emulating Feathertouch controller
Raspberry Pi 2GB with Raspberry Pi OS 32bit
1 year 11 months ago #57351

Please Log in or Create an account to join the conversation.

  • Posts: 821
  • Thank you received: 396

Replied by Hy Murveit on topic KStars v3.4.3 Released

I guess what I was trying to say is that I pulled both indi and kstars well after Jasem's message and still had the issue.
So, I'm not sure it's fixed for those folks that haven't gone through the trouble of setting Dome Ignored.
Hy
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
1 year 11 months ago #57352

Please Log in or Create an account to join the conversation.

  • Posts: 359
  • Thank you received: 26

Replied by Paul on topic KStars v3.4.3 Released

Hy,

As I said, do another pull and it will be fixed - I had the same problem when I did it immediately but after waiting a few hours it was fine.

Paul
Losmandy G11 with Gemini 2 controller
QSI 583/683 monochrome camera with filter wheel
Starlight Xpress Lodestar X2 guide camera
Microtouch Focuser controlled using Arduino UNO emulating Feathertouch controller
Raspberry Pi 2GB with Raspberry Pi OS 32bit
1 year 11 months ago #57354

Please Log in or Create an account to join the conversation.

  • Posts: 1941
  • Thank you received: 416
By the way, it looks like there is no need to use the nightly builds. We are using the stable release at the moment. Another update of the system installed new indi binaries and last night we didn’t experience this issue at all.


Wouter
Wouter van Reeven

ASI6200MM and 7 slot 2" filter wheel with a SkyWatcher Esprit 80 ED on a SkyWatcher HEQ5-Pro
ASI1600MM-Pro Cooled and 5 slot 1.25" filter wheel with an 8" TS Ritchey-Chrétien on a SkyWatcher EQ6-R
1 year 11 months ago #57356

Please Log in or Create an account to join the conversation.

  • Posts: 1117
  • Thank you received: 182

Replied by Jose Corazon on topic KStars v3.4.3 Released


Paul, once the configuration has been changed and saved it will be applied to future installations. I ran into the same trouble initially - thanks to Doug again for figuring out the solution. But the Dome ignore policy still had to be set once and saved for it to take effect.
What Hy is saying is that if you have never changed the configuration, the default upon first install is still Dome lock.
Atlas Pro AZ-EQ, ASI1600MM-Pro, ASI120MM-S, ES102ED, WO-Z61, Nikon D3300, ASI-EFW, ZWO LRGB,Ha,O3,S2 filter set
1 year 11 months ago #57358

Please Log in or Create an account to join the conversation.

  • Posts: 5
  • Thank you received: 2

Replied by Mike on topic KStars v3.4.3 Released

Many thanks to everyone for updating Kstars and EKOS. Today I spent a night session using the scheduler and remote control:



Server: Ubuntu Server 20.04
Client: Ubuntu 20.04
Mount: SW HEQ5 Pro (EQMod)
Camera: ASI 1600 mm, ASI 120 mm
Additional: Astrometry, ZWO EAF, ZWO EFW

Everything went smoothly. Thanks to the developers.

P.S. From Russia with love
The following user(s) said Thank You: Paul Muller
1 year 11 months ago #57422
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 100
  • Thank you received: 11
I have the same question, when will it be available for Astroberry (Raspbian Buster)?

Regards,
Bernd
10" F5 Newton and 130mm F7 Apo on EQ6-R, ZWO EAF focusers, DeepSkyPro 2600c, ASI183MM, RPi4b 8GB
1 year 11 months ago #57435

Please Log in or Create an account to join the conversation.

  • Posts: 247
  • Thank you received: 29

Replied by wotalota on topic KStars v3.4.3 Released

When testing the weather alert with the observatory protection using simulators and the watchdog with the following settings checked.
Watchdog: Park Mount, Park Dome, Weather, Mount Locks
Observatory: Alert, Park
Dome (Rolloff simulator): Mount Locks
Mount: Dome Locks

The weather alert and safe parking of the mount and dome worked fine.

Two things that seem different.

When the weather is bad and a weather alert is already in effect it is possible to unpark the dome. I don't think that could be done before when the dome was checking the weather.

If the mount is using Dome Locks. An attempt to unpark the mount when the dome is parked will result in a driver warning message and the mount will remain parked. However KStars and Ekos will change the mount status to unparked and be out of sync with the driver. But they can be brought back together by first unparking the Dome and then use the driver to unpark the mount.

Edit
Continuing with testing I had some difficulty setting the watchdog > options > Weather field.
Attempting to change it to Weather Meta, was only able to do that after removing all the other weather stations then it accepted the Weather Meta value. But once an additional (actual) weather source was added such as weather simulator it reverted to using that instead. This would not allow more than one weather stations to combine their coverage to close the observatory. In my case it is a RG11 rain detector feeding into Weather Proxy driver combined with Vantage driver using Weather Meta driver.
Mach1, TS86SDQ, ASI071, ASI174, OAG, focusPro
The following user(s) said Thank You: Jasem Mutlaq
Last edit: 1 year 11 months ago by wotalota. Reason: Additional watchdog observation & typo
1 year 11 months ago #57438

Please Log in or Create an account to join the conversation.

Time to create page: 0.801 seconds